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Unable to Obtain a Lock when Using PHYLock

Problem:

Image for Windows reports that PHYLock cannot obtain a lock on a system containing third-party software/drivers that provide disk-related functionality.

Cause:

Some drivers can interfere with I/O to or from the PHYLock driver.  This can prevent PHYLock from being able to obtain a lock or from working properly after it has.

Solutions:

  • Determine if the system contains one or more drivers that may be interfering with PHYLock. To do this, proceed as follows:

    1. Navigate to the following registry key:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}

    2. Locate the value named UpperFilters. By default, and with only PHYLock installed, the data for this value will contain phylock and PartMgr. If you see anything else, please double-click the UpperFilters value, select its entire contents, copy it to the clipboard, and paste it into an email to support@terabyteunlimited.com for review. TeraByte support will attempt to determine what software may be in use and if/how it is affecting PHYLock.

      Note: Do not make any changes to the UpperFilters value! Doing so can potentially cause serious problems, including rendering your system unbootable.

  • Use Microsoft's Volume Shadow Copy service (VSS) instead of PHYLock. To do this, enable the Use VSS When Available option in Image for Windows (this doesn't require a reboot). You must be running Windows 2003 or later.

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