Page 1 of 1

Recent issue with VSS backups

Posted: Tue May 23, 2023 4:45 pm
by kenhagin
I have 2 Windows Home Server v1 servers, based on Windows Server 2003 32-bit. These are limited to running version 3.56. I have nightly scheduled backups for both. On one of them, over the last 2 weeks, it has been failing with the following error trail:

[05/23/2023 11:16:39 AM] [VSS END]
[05/23/2023 11:18:10 AM] An error occurred gathering data for the partition starting at LBA 41945715.
[05/23/2023 11:18:10 AM] This may be a temporary condition or the file system may need to be repaired.
[05/23/2023 11:18:10 AM] You can use the ""Unused Sectors"" option to work around file system issues.
[05/23/2023 11:18:10 AM] Deleting incomplete or failed backup.
[05/23/2023 11:18:10 AM] Elapsed 0:00:01:38
[05/23/2023 11:18:10 AM] Operation Completed with Error Code 75 (Failed)
[05/23/2023 11:18:10 AM] Stop

The LBA appears to be the start of the D: partition. I ran chkdsk /r on C: and D: (both on the same physical disk), with no issues. When I check vssadmin list writers, I notice the System Writer is waiting for completion. This problem is only with one of the systems. I tried manual backup - same issue. I switched from VSS to PhyLock, and it worked. I would rather keep using VSS if I can figure out what the actual problem is and resolve it. I followed some instructions to cleanup VSS, and after a few reboots, I had all VSS writers in a clean state. One attempt at a backup produced the same error, and the System Writer is again waiting for completion.

Also, I looked through the manual for "unused sectors" and I did not find anything I think applies to this situation, but I'm no expert on this...

Anyone experienced enough with VSS to explain this to me? Thank you.

Re: Recent issue with VSS backups

Posted: Sun May 28, 2023 11:05 pm
by Bob Coleman
Far from an expert here, but I think the point regarding unused sectors is that if unused sectors, therefore all sectors, are backed up, everything may be backed up even if the file system is screwed up.

Re: Recent issue with VSS backups

Posted: Sun May 28, 2023 11:14 pm
by TeraByte Support
Maybe you have bad sectors? Run something like spinrite or drive makers diag utility. If it's related to VSS see the event log. Unused means it won't try to gather information and just do everything raw. Run chkdsk /f to fix any fs issues (should run memtest first so chkdsk doesn't make things worse).