Image for Linux 4.0 upgrade

User discussion and information resource forum for Image products.
Post Reply
sirdinaden
Posts: 5
Joined: Sat May 23, 2020 11:25 am

Image for Linux 4.0 upgrade

Post by sirdinaden »

Hi. I'm using Ubuntu 22.04. I've downloaded the new update and having extracted it, The usual ./setup command fails, saying there's missing libraries!! I'm no expert but have checked out the list given and the only one missing appears to be libpng12-0:i386. This has been mentioned in other install failures. If I'm right ?? can someone direct me to a solution or perhaps I'm barking up the wrong tree altogether! Thanks.
TeraByte Support(PP)
Posts: 1662
Joined: Fri Aug 12, 2011 12:51 am

Re: Image for Linux 4.0 upgrade

Post by TeraByte Support(PP) »

The KB article hasn't been updated yet for V4, which no longer uses libpng12/libncursesw5. IFL V4 uses the libpng16 and libncursesw6 versions (names will vary depending on the distro).
sirdinaden
Posts: 5
Joined: Sat May 23, 2020 11:25 am

Re: Image for Linux 4.0 upgrade

Post by sirdinaden »

I emphasize, I'm no expert but it appears that libncursesw6 is installed but there's no sign of libpng16 !
TeraByte Support
Posts: 3660
Joined: Thu May 05, 2011 10:37 pm

Re: Image for Linux 4.0 upgrade

Post by TeraByte Support »

the ./setup uses tbosdt which is where the dependencies are located. It says ncurses5w but that is now ncurses6w (32 bit version)

If you want to check it, ensure you have upx package installed and from the directory with tbosdt in it:

upx -d tbosdt
ldd tbosdt
Brian K
Posts: 2275
Joined: Fri Aug 12, 2011 1:11 am
Location: NSW, Australia

Re: Image for Linux 4.0 upgrade

Post by Brian K »

Can you let us know when the KB article has been updated?
TeraByte Support(PP)
Posts: 1662
Joined: Fri Aug 12, 2011 12:51 am

Re: Image for Linux 4.0 upgrade

Post by TeraByte Support(PP) »

Brian K wrote: Mon May 20, 2024 8:46 am Can you let us know when the KB article has been updated?
Yes.
TeraByte Support(PP)
Posts: 1662
Joined: Fri Aug 12, 2011 12:51 am

Re: Image for Linux 4.0 upgrade

Post by TeraByte Support(PP) »

The KB article has been updated with the commands for the current versions of Ubuntu, Linux Mint, and Debian. The commands are likely the same for recent prior versions of those distros, but haven't been tested with them yet.
Brian K
Posts: 2275
Joined: Fri Aug 12, 2011 1:11 am
Location: NSW, Australia

Re: Image for Linux 4.0 upgrade

Post by Brian K »

Thank you. IFL v4 installed in Linux Mint 21.3.
sirdinaden
Posts: 5
Joined: Sat May 23, 2020 11:25 am

Re: Image for Linux 4.0 upgrade

Post by sirdinaden »

Hi. Yes, now works for Ubuntu 22.04. Thanks.
Post Reply