TBI Notify posts No Backup warning but log shows success

User discussion and information resource forum for Image products.

TBI Notify posts No Backup warning but log shows success

Postby merckxist » Wed Oct 25, 2017 10:38 am

Since updating to Win 10 1709, TBI Notify is sending a message to Windows Notifications that a backup hasn't been done in X days. However, my daily scheduled backup has been running without error every day and the Image for Windows Summary Log confirms that is so. The IFW version is 3.09 (x64) and TBI Notify is v1.01.1. This discrepancy between the No Backup warning and the summary log was not occurring in Win 10 1703 running the same versions of IFW and TBI Notify.

[edit 11/13]I tried updating to IFW v3.12 which also installed TBI Notify v1.02.0 on 11/9, but the Win Notifications have returned. No scheduled backups have actually failed since Win 10 was installed on 10/19. The warning is not posted every day, but shows up from time to time with a different number of days being missed. The number of days missed doesn't seem to be related to the IFW upgrade since that was 4 days ago and the "days missed" said 2. The only 2-day-old event was the previous differential backup before today. My backup schedule is FDDDDDD starting each Sunday, so no differential backup has happened in 2 days, but there was a successful full backup in between.
merckxist
 
Posts: 9
Joined: Fri Jun 06, 2014 2:00 pm

Re: TBI Notify posts No Backup warning but log shows success

Postby merckxist » Fri Nov 24, 2017 11:42 am

No improvement since updating to latest IFW 3.13 which also included TBI 1.02.0. Most days I get a warning that "no backup in x days" where "x" increments by a day, except when an alert gets skipped, then the following day the counter starts over again at the configured threshold of 2. No actual backups have been missed for weeks.
I see this topic get views, but no +1 posts, so I'll assume this is a "local" problem. Since I run my backups with a perl script in Windows Task scheduler, I have an alternate failure notification method that has been reliable for years, so I'll just turn off the nuisance warnings from TBI for now. It seemed to be a nice 2nd level failure mechanism until Win 10 1709, but its not valid (for me) at this point.
merckxist
 
Posts: 9
Joined: Fri Jun 06, 2014 2:00 pm

Re: TBI Notify posts No Backup warning but log shows success

Postby timg11 » Sat Dec 09, 2017 10:32 am

I have the same issue - had to turn off notifications.
timg11
 
Posts: 171
Joined: Sun Oct 02, 2011 9:31 am

Re: TBI Notify posts No Backup warning but log shows success

Postby TeraByte Support » Sat Dec 09, 2017 12:50 pm

perhaps it has to do with the av program you're using preventing
communications between the two programs? what are you guys using?

"timg11" wrote in message news:14451@public.image...

I have the same issue - had to turn off notifications.

TeraByte Support
 
Posts: 2510
Joined: Thu May 05, 2011 3:37 pm

Re: TBI Notify posts No Backup warning but log shows success

Postby merckxist » Tue Dec 12, 2017 11:30 am

My AV is Avast Free v17.8.3705. I could try adding exclusions to the AV for imagew64.exe and tbinotify.exe or whatever the "two programs" are that may be getting blocked. I've excluded imagew64.exe in the past, but at some point it got dropped from the exclusion list.
merckxist
 
Posts: 9
Joined: Fri Jun 06, 2014 2:00 pm

Re: TBI Notify posts No Backup warning but log shows success

Postby merckxist » Thu Dec 14, 2017 12:28 pm

I tried adding exclusions for imagew64.exe and tbinotify.exe in the AV settings and restarting tbinotify, but the alert for "no backup" has started coming up again. I've been using the AV product for several years without exclusions for TB programs but the notifications only started to appear after the Win 10 1709 upgrade.
merckxist
 
Posts: 9
Joined: Fri Jun 06, 2014 2:00 pm

Re: TBI Notify posts No Backup warning but log shows success

Postby mjnelson99 » Thu Dec 14, 2017 2:31 pm

I just got an additional update for 1703. Not sure when I will be
offered the newer version.

On 12/14/2017 1:28 PM, merckxist wrote:
> I tried adding exclusions for imagew64.exe and tbinotify.exe in the AV settings and restarting tbinotify, but the alert for "no backup" has started coming up again. I've been using the AV product for several years without exclusions for TB programs but the notifications only started to appear after the Win 10 1709 upgrade.
>
>
mjnelson99
 
Posts: 779
Joined: Thu Aug 11, 2011 6:24 pm

Re: TBI Notify posts No Backup warning but log shows success

Postby TeraByte Support » Thu Dec 14, 2017 6:40 pm

they show when you exit it, run it again? or just after sitting there for a
long time. If the earlier one, then send the software\terabyte
unlimited\image registry data (right click key, export). Email it to
support@


"merckxist" wrote in message news:14492@public.image...

I tried adding exclusions for imagew64.exe and tbinotify.exe in the AV
settings and restarting tbinotify, but the alert for "no backup" has started
coming up again. I've been using the AV product for several years without
exclusions for TB programs but the notifications only started to appear
after the Win 10 1709 upgrade.

TeraByte Support
 
Posts: 2510
Joined: Thu May 05, 2011 3:37 pm

Re: TBI Notify posts No Backup warning but log shows success

Postby merckxist » Sat Dec 16, 2017 3:38 pm

TeraByte Support wrote:
> they show when you exit it, run it again? or just after sitting there for
> a
> long time. If the earlier one, then send the software\terabyte
> unlimited\image registry data (right click key, export). Email it to
> support@
>
>
> "merckxist" wrote in message news:14492@public.image...
>
> I tried adding exclusions for imagew64.exe and tbinotify.exe in the AV
> settings and restarting tbinotify, but the alert for "no backup" has
> started
> coming up again. I've been using the AV product for several years without
> exclusions for TB programs but the notifications only started to appear
> after the Win 10 1709 upgrade.

The sequence was: stop tbinotify, enable the exclusions for imagew64.exe and tbinotify.exe, start tbinotify and configure it to monitor backups and alert for no backup in two days. There was no immediate alert posted. The alert was not posted until two days after tbinotify was restarted. That seemed to be a "long time" so I sent no data export.
merckxist
 
Posts: 9
Joined: Fri Jun 06, 2014 2:00 pm


Return to Image for DOS/Linux/Windows