Toshiba laptop cannot boot USB unless UEFI?

User discussion forum for items related to technology in general.

Toshiba laptop cannot boot USB unless UEFI?

Postby ohaya » Sat Mar 18, 2017 11:29 am


I was helping my son recover a Toshiba 17" laptop (a P275 something). It's got an i7 processor so it seems like it's fairly recent.

Anyway, I was trying to boot BING (tried both USB stick and USB DVD drive) from USB, and I couldn't get it to even see the drive, even after disabling Secure Boot and changing from UEFI to CSM.

I found this:


and the post on Sept. 29, 2015 by "Barth_bs" he says:

"you must be make an UEFI Boot USB Stick"

"and change partition scheme and target system type to :
GPT partition scheme only for UEFI

and toshiba can only detect USB Boot with UEFi format...

try it.... don't forget to backup your data before.

If I'm reading that correctly, he is saying that even with CSM and Secure Boot disabled, this laptop won't recognize a USB boot device and it only recognizes boot media that is UEFI?

Does anyone know if that is really the case? Do they actually disable booting from USB unless it is UEFI?

Just curious, in case I run across this again some time down the road :(...

Posts: 210
Joined: Fri Jan 06, 2012 4:40 pm

Re: Toshiba laptop cannot boot USB unless UEFI?

Postby Brian K » Sun Mar 19, 2017 12:04 am


So you have disabled Secure Boot and are using Other OS (Legacy setting). Make sure you haven't disabled Secure Boot and are still using UEFI.

You have enabled CSM.

In the boot menu can you see 2 entries for the UFD and 2 entries for the CD. One will say UEFI. Use the other one.
Brian K
Posts: 1811
Joined: Thu Aug 11, 2011 6:11 pm
Location: NSW, Australia

Return to Technology