OSD Tool Script 4.43 - Camera driver error.

User discussion and information resource forum for the TeraByte OS Deployment Tool Suite.

OSD Tool Script 4.43 - Camera driver error.

Postby ostapvoip » Sun Sep 20, 2020 11:41 pm

Hi,

1) Lenovo ThinkPad W500 laptop
2) The original image of Microsoft Windows 10 Home SL is installed
3) Updated through the parameters, after the update, the system version is [Version 10.0.18363.1082]
* Built-in webcam works, there are no errors in the Device Manager (for the camera)
* Integrated Camera ID: USB\VID_17EF&PID_4807&REV_3134&MI_00
* No programs were installed, no settings were made
4) OSD Tool Script 4.43 was launched from under WinPE and executed: Remove All drivers
5) After that, the built-in webcam stopped working. All attempts to make it work have failed.

Registry files and screenshots (before OSDTool and after OSDTool) http://137615.selcdn.com/Other/OSDTool_Camera_error.7z

Best regards, Viktor.
ostapvoip
 
Posts: 56
Joined: Fri Feb 08, 2013 3:32 pm

Re: OSD Tool Script 4.43 - Camera driver error.

Postby Eric » Wed Sep 23, 2020 1:41 am

Hello,
Many thanks for that feedback.
After cleaning all drivers, can you try to install the usbvideo.inf driver? (using osdtool, select to install a specific driver, go to \Windows\System32\DriverStore\FileRepository\usbvideo.inf_amd64_3422d33fc3a3508a, select to install a normal driver...).
You can also try to install it in the new Windows where the camera does not work.
If that works, it means Windows is unable to reinstall it by itself. Which means I have to find a solution to not remove it.
Thanks,
Eric
 
Posts: 196
Joined: Mon Sep 05, 2011 11:53 am
Location: France


Return to OSD Tool Suite