CopyP2V won't boot

User discussion and information resource forum for the TeraByte OS Deployment Tool Suite.

CopyP2V won't boot

Postby Beemusic » Thu Mar 08, 2018 11:28 am

Hello,

I've attempted numerous times to create a virtual from a physical and always end up with an "inaccessible boot device" error when attempting to boot the resultant virtual.

I've taken an image of the physical system, then run copyp2v.tbs (running TBOSDT As admin) (also did it by right clicking on the copyp2v.tbs script and run as admin), I've also run the TBOSDT (as admin) on the physical box itself (while running) and had it create the virtuals.
This is on a Windows 10 (64bit) computer.
I've created VHDX (dynamic); VHD (dynamic); VMDK (dynamic) and have attempted to boot the resultant VHD/VHDX on HyperV; attempted to boot VMDK in VMWare Workstation 14.
In each case, the Windows 10 logo appears, "hour glass" circle starts to circle, then blue screens to the Unable to start the system with the "inaccessible boot device"
I've tried IDE virtual drives; SCSI virtual drives; secure boot; no secure boot etc.
I've pulled/converted the virtual drives at least 4 times for each type and still get the same results.

Is there something I'm missing? I've watched the videos and read the manuals. It appears to me the script is pretty much automatic in it's conversion.
Is there something else I'm supposed to do before booting the virtual?

Any help is greatly appreciated.

Thanks,
Beemusic
Beemusic
 
Posts: 6
Joined: Wed Jan 15, 2014 4:49 pm

Re: CopyP2V won't boot

Postby TeraByte Support » Sat Mar 10, 2018 10:45 pm

Run chkdsk /f on your source drives before copying or creating the image.

Ensure using the latest versions of the scripts and programs.

If still problem, it means that Windows doesn't have the driver that it
want's for that virtual environment (the defaults are installed). You can
connect the drives to VirtualBox to try as well. Check the virtual
environment chipset being used as well.




"Beemusic" wrote in message news:14780@public.tbosdt...

Hello,

I've attempted numerous times to create a virtual from a physical and always
end up with an "inaccessible boot device" error when attempting to boot the
resultant virtual.

I've taken an image of the physical system, then run copyp2v.tbs (running
TBOSDT As admin) (also did it by right clicking on the copyp2v.tbs script
and run as admin), I've also run the TBOSDT (as admin) on the physical box
itself (while running) and had it create the virtuals.
This is on a Windows 10 (64bit) computer.
I've created VHDX (dynamic); VHD (dynamic); VMDK (dynamic) and have
attempted to boot the resultant VHD/VHDX on HyperV; attempted to boot VMDK
in VMWare Workstation 14.
In each case, the Windows 10 logo appears, "hour glass" circle starts to
circle, then blue screens to the Unable to start the system with the
"inaccessible boot device"
I've tried IDE virtual drives; SCSI virtual drives; secure boot; no secure
boot etc.
I've pulled/converted the virtual drives at least 4 times for each type and
still get the same results.

Is there something I'm missing? I've watched the videos and read the
manuals. It appears to me the script is pretty much automatic in it's
conversion.
Is there something else I'm supposed to do before booting the virtual?

Any help is greatly appreciated.

Thanks,
Beemusic

TeraByte Support
 
Posts: 2584
Joined: Thu May 05, 2011 3:37 pm

Re: CopyP2V won't boot

Postby Beemusic » Mon Mar 12, 2018 3:32 pm

So check disk is fine - no issues.
Using the latest download version of IFW/TBOSDT etc. from Terabyte.
So how do I go about getting this "driver" that Windows wants for the Virtual environment?
I'm able to build virtual systems in either Hyper-V or VMWare with no issues, but not able to use the VHD/VHDX/VMDK created by the copyp2v.tbs script.
It would be nice to be able to use this process to create virtuals.

I'll download and try this VirtualBox and post aftewards.

Thanks in advance,
Brian
Beemusic
 
Posts: 6
Joined: Wed Jan 15, 2014 4:49 pm

Re: CopyP2V won't boot

Postby Beemusic » Tue Mar 20, 2018 11:20 am

Hello,

I have been completely unsuccessful in getting a physical to virtual (P2V) to actually boot in any type of virtual environment when using the CopyP2V, whether from an existing image (newly taken) or from the physical system itself using copyp2v to create the image/virtual.
I've tried on 2 different systems now (windows 10) and always end up with the "inaccessible boot device" error.
These are newly built Windows 10 systems, fresh from Dell and fresh installs.
Is there something in the walk-through or script that is missing regarding Windows 10?
I'd really like to be able to virtualize these systems.

Has anyone else been able to virtualize a Win-10 system? Any advice?

Thanks in advance,
Bee
Beemusic
 
Posts: 6
Joined: Wed Jan 15, 2014 4:49 pm

Re: CopyP2V won't boot

Postby TeraByte Support(PP) » Wed Mar 21, 2018 9:06 am

I use Workstation 14 and just ran a quick test converting one of my Windows 10 UEFI systems and it booted up fine. It's possible that the issue may be specific to something in the Dell systems you're trying to convert. I assume they're configured as UEFI. In the converted VM, have you tried doing a boot repair or rebuilding the BCD? This could be done from a Windows 10 ISO or TBWinRE ISO. You could look at the BCD output and see if it's broken somewhere. The BCD Edit feature in Partition Work (BIBM or IFL GUI) could also be used to look for broken references.
Paul Purviance
TeraByte Support
TeraByte Support(PP)
 
Posts: 1230
Joined: Thu Aug 11, 2011 5:51 pm

Re: CopyP2V won't boot

Postby TeraByte Support » Thu Mar 22, 2018 9:49 am

Also the VM needs UEFI support if coming from UEFI system.


"TeraByte Support (PP)" wrote in message news:14807@public.tbosdt...

I use Workstation 14 and just ran a quick test converting one of my Windows
10 UEFI systems and it booted up fine. It's possible that the issue may be
specific to something in the Dell systems you're trying to convert. I assume
they're configured as UEFI. In the converted VM, have you tried doing a boot
repair or rebuilding the BCD? This could be done from a Windows 10 ISO or
TBWinRE ISO. You could look at the BCD output and see if it's broken
somewhere. The BCD Edit feature in Partition Work (BIBM or IFL GUI) could
also be used to look for broken references.

TeraByte Support
 
Posts: 2584
Joined: Thu May 05, 2011 3:37 pm

Re: CopyP2V won't boot

Postby Eric » Fri Mar 23, 2018 9:49 am

Hello,
For me, with VirtualBox, it works fine. I had other errors than the 'inaccessible boot device" one, but I could deal with them. Replacing the bootx64.efi file was one of the correction I had to do (but it is due to my system).
Can you send your original Software and System registres to Terabyte support so we can check the drivers?
Thanks
Eric
 
Posts: 144
Joined: Mon Sep 05, 2011 11:53 am
Location: France

Re: CopyP2V won't boot

Postby Eric » Sat Mar 24, 2018 1:53 am

The System and Software files are in the following directory of your image:
\Windows\System32\config.
Can you extract them and send them?
Thanks
Eric
 
Posts: 144
Joined: Mon Sep 05, 2011 11:53 am
Location: France

Re: CopyP2V won't boot

Postby Beemusic » Wed Mar 28, 2018 11:54 am

Eric,
I extracted the files you requested and sent them to you at support@terabyteunlimited.com.
Let me know if you need more info.
Beemusic
 
Posts: 6
Joined: Wed Jan 15, 2014 4:49 pm

Re: CopyP2V won't boot

Postby TeraByte Support » Thu Mar 29, 2018 4:10 pm

It doesn't look that that made it. How large is the file? can you zip them
up? Send an email without the attachment first, saying you're sending then
send.


"Beemusic" wrote in message news:14823@public.tbosdt...

Eric,
I extracted the files you requested and sent them to you at

[
support@terabyteunlimited.com
](mailto:support@terabyteunlimited.com)

..
Let me know if you need more info.

TeraByte Support
 
Posts: 2584
Joined: Thu May 05, 2011 3:37 pm


Return to OSD Tool Suite