TBCMD not recognizing my drives

User discussion and information resource forum for scripting of TeraByte products using script lanugages such as TBScript, VBScript, Batch Files, and more.
Post Reply
WillASM
Posts: 7
Joined: Sat Dec 03, 2011 2:50 pm

TBCMD not recognizing my drives

Post by WillASM »

Decided to revisit tbscript and improve on some of my scripts I wrote years ago.
Immediately noticed that all the scripts I was using to access the Bootit EMBR partition no longer work?
For a short example...

Code: Select all

    sub main()

    dr=getdrive()                        ; This works as expected
    printl("current drive is ",dr)

    getdrvltrinfo()
    h=gethdinfo(0)                       ; This does not work
    printl("the HD number is ",h.num)

    getdrvltrinfo(0)
    getkey("Press Any Key To Exit...")

    end sub
gethdinfo fails to detect any drive.

I also tried to run from TBCMD

Code: Select all

list hd 0
and that just gives me a "Invalid drive" response?

I did recently wipe my drive to re-install win 10 and upgraded bootit bm as well.
That all went fine. I can boot to all my partitions just fine and creating and restoring images
works perfectly. I'm at a loss trying to figure out why gethdinfo() is no longer working though??

Any suggestions? Thanks, William
TeraByte Support
Posts: 3102
Joined: Thu May 05, 2011 10:37 pm

Re: TBCMD not recognizing my drives

Post by TeraByte Support »

You have to be running as administrator for gethdinfo to work.
WillASM
Posts: 7
Joined: Sat Dec 03, 2011 2:50 pm

Re: TBCMD not recognizing my drives

Post by WillASM »

Thank you! Can't believe I didn't catch that. Every time I do a clean install there is always some program I forget to set the permissions on. All good now, thanks again.
Post Reply