Switch to full style
User discussion and information resource forum for Image products.
Forum rules
Post a reply

Resizing/sliding Linux ext4 partitions kills OS

Wed Jun 12, 2019 12:11 pm

Hello everyone. I can't figure out what I'm doing wrong. I'm trying to resize one of my ext4 partitions smaller, then trying to slide it past the swap partition and next to my /home partition to then resize it bigger. It works during partition work under both BIBM v1.52 and IFL v3.26, but then I can't boot into my Linux Mint 19 install. My specifics:

Desktop machine with multiple HDD's and SSD's installed.
Linux Mint 19.1 installed to it's own dedicated SSD (Samsung EVO 860, 1TB)
Drive is partitioned as:
/boot
/
swap
/home

Have tried the resize and slide in both BIBM 1.52 and IFL 3.26. I even tried booting with Gparted and ran into same problem.

I suspect this has something to do with UUID's but don't know how to tackle this. Can anyone help? Thank you.

Re: Resizing/sliding Linux ext4 partitions kills OS

Wed Jun 12, 2019 3:16 pm

Gary, can you try the latest versions, This issue with resizing smaller has been fixed.

Re: Resizing/sliding Linux ext4 partitions kills OS

Thu Jun 13, 2019 1:17 pm

Hello Brian.

What I did was go to Gparted and download their latest iso, make it into a USB bootable and then do the partition work from there. This time I applied "change UUID" to each partition and now it seems to work. So go figure.

I will however go ahead and update both my BIBM and IFL software and when I have a chance, experiment again using only Terabyte solutions. After all, if I f**k things up I can just copy back my backup image that I have thanks to IFL!

Thanks again.
Post a reply