Page 1 of 1

Error running IFL from Linux Mint

PostPosted: Sun Dec 10, 2017 2:28 pm
by rustleg
I get the same error as in a previous post by powhyfo 11 Sept.

Trying to execute ./imagel I get
./imagel: error while loading shared libraries: cannot open shared object file: No such file or directory

I do have installed. I tried putting a file of that name in the directory where IFL is installed, being a link to the file /usr/lib/x86_64-linux-gnu/ , but I get the same error. The actual file in that same directory is a link to

How do I get IFL to recognise this library file?

Re: Error running IFL from Linux Mint

PostPosted: Sun Dec 10, 2017 5:26 pm
by TeraByte Support(PP)
What version and kernel version of Mint are you using?

Have you run the commands from the KB article to install the 32-bit libraries?

Re: Error running IFL from Linux Mint

PostPosted: Mon Dec 11, 2017 12:49 am
by rustleg
Sorry, should have looked in the knowledge base. I have installed the extra dependencies and it works now.

However I do have a problem with the files it creates. First they don't show up in file manager or the GUI terminal until I reboot. Even switching to a non X terminal they don't show up.

But the real problem is that there seems some corruption in the file system. I took an image of my Windows 10 system which produced 6 files as normal (I limit size to 4GB). I rebooted and then saw the files in the file manager. I then took an image of another partition. When I rebooted again the new image appeared (a small partition) but the .tbi file of the new Windows image was then showing the same size as the new partition, not the 4.3GB it should be. I tried it again with a third partition (again less than 4GB) and this appeared after a reboot. This time the .1 Windows image file showed an identical size to the new partition image.

The partition holding the images is a NTFS partition. I use this for common data seen by all my systems.

I need to see how to fix the corruption and don't have the time now, but I thought I'd report this problem in the meantime.

I'm running Linux Mint 17.3. Kernel is 3.13.0-100-generic #147-Ubuntu SMP Tue Oct 18 16:48:51 UTC 2016

Re: Error running IFL from Linux Mint

PostPosted: Mon Dec 11, 2017 8:41 am
by TeraByte Support(PP)
Is Windows 10 Fast Startup for sure disabled? That option can easily cause corruption depending on how the system is used.

When you're saving the image is the via the OS option (the NTFS partition is mounted in Mint) or is it via the Direct option (not mounted in Mint)?

Re: Error running IFL from Linux Mint

PostPosted: Mon Dec 11, 2017 9:27 am
by rustleg
Fast startup is definitely disabled, I checked it in Windows and also in BIBM partition properties.

I used the File Direct option but to a mounted partition. I didn't consider the OS option as I never used that before and just ignored it. I hadn't realised that I needed to unmount the partition where the file is to be saved if using Direct. I imagined that you'd need it to be mounted to save the file using the Linux file system. So I guess you are using your own code to manage the file system which seems a little surprising, but of course you know all about file systems (and I don't!). It might be worth a few words in your readme.txt and/or manual to warn users.

I tried it again just now (having repaired the partition using Windows) and it seems ok using the OS option which I'll use in future.

I have to say that IFL is much faster than IFD, maybe by a factor of 2 to 3x, presumably as it has access to much more memory and maybe better drivers. I am impressed with the small size (iso approx 93MB) and I would guess the OS is running from RAM? Wish I had discovered IFL before now. In fact I'd be happy to provide a positive review if you tell me how/where (I rarely do reviews but your stuff is brilliant).

1. I tried running from a normal user account in Linux rather than root and it didn't object. Is this ok?
2. Running from my current Linux also allows me to do other stuff at the same time. Are there any restrictions on this?
3. Is there a way of integrating IFL within BIBM instead of IFD? (not important but might be nice)

Re: Error running IFL from Linux Mint

PostPosted: Mon Dec 11, 2017 10:21 am
by TeraByte Support(PP)
When you boot the IFL media it runs from RAM. Linux usually provides better support and much faster access to the drives than the DOS environment, which is often limited due to the BIOS.

IFL can be run as a normal user as long as it has the necessary privileges.

You can do other things while IFL is running. Depending on what you're doing or accessing it might be slower (same as in Windows). Keep in mind that you shouldn't back up mounted drives either. For example, you shouldn't back up the Mint system while it's running.

If you setup IFL to boot from its own partition you could add it to the BIBM menu (BIBM is not a Linux environment so it can't run IFL directly like it does IFD). Another option is to add IFL to the GRUB menu used by Mint (the makeGRUB script does this).

Re: Error running IFL from Linux Mint

PostPosted: Mon Dec 11, 2017 11:39 am
by rustleg
I have made a partition for IFL and added it to the BIBM menu so this is the most likely way I'll run it. Nice and simple and I don't have to remember not to try to backup the Mint partition (I knew that but I'm daft sometimes :| ). Also it's quick even for 40GB or so of Windows 10 on a SSD. Boot takes about 20 seconds but the speed difference v IFD in BIBM more than makes up for it.