Restoring W7 system partition and TPM behavior

User discussion and information resource forum for Image products.

Restoring W7 system partition and TPM behavior

Postby jerelyn » Tue Nov 22, 2011 11:36 am

I bought IFW with the hopes that exchanging a defective laptop would not require me to reinstall the OS (Win 7 Ultimate).

To that end I took an image of the old laptop's disk using the TBWinPE boot disk and restored it to the new laptop (same hardware, though with a new BIOS version I later discovered) using the same disk. (I have tried this using an encrypted OS and unencrypted OS, and there was no difference in behavior.)

While this image otherwise worked (minus a few apps and the OS wanting to be re-activated), the TPM would no longer initialize. I tried this two ways:

Method A - Using the installed drivers:
- Start Menu -> Infineon Security Platform Solution -> Manage Security Platform (right-click, run as admin)
- select User Settings. Prompt appears asking "The Security Platform state is "Not Initialized". Do you wanto to start initialization now?"I click "Yes".
- In the dialog that appears, I chose "Advanced INitialization" (though I've tried this with Quick Initialization with no change in behavior) and selected "Next >"
- I come to a screen that states "Please shut down your system and start it again manually. Follow the instructions at the prompt in the boot screen. Start the Wizard again after the system has restarted." I click the shutdown button.
Problem: At this point, when I restart the system, I should boot into the TPM wizard. This does not happen. Instead it boots straight into Windows where I can repeat the above steps with no greater success

Method B - Windows Drivers
- Start Menu - in run window: "tpm.msc"
- At top right of window, select "Initialize TPM..."
- Window appears that tells me I'll need to shutdown, and includes a "Shutdown" button, which I click
Problem: Error window appears that states: "Initialization failed. A general error was detected when attempting to acquire the BIOS's response to a Physical Presence command. Error code 0x80290300"

Any suggestions or insights would be GREATLY appreciated. Perhaps there is a setting I need to use when recovering or creating the image?

More information: The darndest thing is that when I later wiped the disk and installed Win 7 Ultimate from scratch, the TPM failed at that point as well. And then failed when I recovered the original OS install. Yet prior to recovering the disk image, using the original OS install, I was able to initialize and then clear the TPM. (I also tried this with a system where I had not done that initial that point I had thought I had a faulty TPM chip.) So the TPM was working, and then after recovering an IFW image, it failed. Somehow the image did something with a lasting effect
Posts: 2
Joined: Mon Nov 21, 2011 11:49 pm

Re: Restoring W7 system partition and TPM behavior

Postby jerelyn » Wed Nov 23, 2011 10:35 am

I wanted to follow up on my own post to share how this was resolved, in case someone else encounters this difficulty using IFW on Samsung's Series 7 Slate.

There was a BIOS update from Samsung today that gave me the opportunity to flash the BIOS, and that cleared the problem. I’m not sure if it’s just the act of flashing the BIOS, or if this specific update was intended to target a problem with their TPM implementation, but since they won’t allow you to re-flash an existing version, I’m not keen to experiment further until our “spare” laptop arrives (we like this design enough that we thought a spare would be useful for when the inevitable servicing needs to happen).

Conventional approach is for the TPM pre-startup functionality to reside in the BIOS, and IFW doesn't touch the BIOS, so chances are Samsung is doing something unconventional. Whether they’ll tell me the specifics of this when I get my callback in a few days from higher-level support is anyone’s guess, but if I do learn anything useful, I will post that so that this knowledge is available for the next unfortunate S7S user. I’d love to find a reliable solution that would allow me to use IFW without further risk.
Posts: 2
Joined: Mon Nov 21, 2011 11:49 pm

Return to Image for DOS/Linux/Windows