IFW WinRE won't boot in UEFI

User discussion and information resource forum for Image products.
Post Reply
crawfish
Posts: 36
Joined: Mon Jun 24, 2013 9:49 pm

IFW WinRE won't boot in UEFI

Post by crawfish »

I've been using a 32-bit Windows 10 VM (latest VMware Player) to create my IFW boot media, and I just tried it on a UEFI system for the first time, and it wouldn't boot. After enabling CSM, it booted fine. The host machine for the VM is not UEFI, don't know if that matters. The new UEFI system is an Asus TUF Gaming B550 Pro mobo, and while I haven't yet installed Windows on it, the USB drive holding the installation media did boot under UEFI, and I created it on the same machine that hosts the VM I use for IFW WinRE. Any ideas?
TeraByte Support(PP)
Posts: 1497
Joined: Fri Aug 12, 2011 12:51 am

Re: IFW WinRE won't boot in UEFI

Post by TeraByte Support(PP) »

The normal TBWinRE boot media created in x86 Windows won't boot on a UEFI BIOS that expects x64.

I assume the USB Windows installation media is x64 Windows.
Paul Purviance
TeraByte Support
crawfish
Posts: 36
Joined: Mon Jun 24, 2013 9:49 pm

Re: IFW WinRE won't boot in UEFI

Post by crawfish »

Ah well, I guess that means sacrificing some 32-bit programs I like to include. (You are correct the Windows installation media is x64.)
TeraByte Support(PP)
Posts: 1497
Joined: Fri Aug 12, 2011 12:51 am

Re: IFW WinRE won't boot in UEFI

Post by TeraByte Support(PP) »

If you don't require it to be UEFI bootable or match the installed Windows architecture you can boot it in Legacy mode (as you already tested).
Paul Purviance
TeraByte Support
crawfish
Posts: 36
Joined: Mon Jun 24, 2013 9:49 pm

Re: IFW WinRE won't boot in UEFI

Post by crawfish »

I've adapted to the 64 bit WinRE and already had occasion to use it. It booted fine under UEFI and Secure Boot, and I restored my Bitlockered OS partition in the encrypted state by first unlocking it with manage-bde. It worked perfectly.
Post Reply