Switch to full style
User discussion and information resource forum for BootIt Next Generation
Forum rules
Post a reply

Problem with Dell Laptop

Tue Jul 10, 2012 1:04 pm

Hi, my Dell Studio laptop is about 2 years old. I used bootitng to resize and create a data partition without installing bootitng. Recently, I shrank the extended data partition and installed Ubuntu 12.04 with the default grub loader in mbr and all went well.
I wanted to get rid of the two Dell partitions, so I copied bootmgr and boot from the utility partition to windows 7 (not an easy task since contrary to the instructions, boot didn't like to be copied while windows was running). I set windows 7 as active and all was well.
So I went ahead and deleted the Dell Utility and Recovery partitions. The machine would not boot. I undeleted those partitions - no luck.
I had images of both, so I tried to restore the images, but paste was greyed out. I deleted the partitions again and now I could paste the dell utility, but couldn't paste the Recovery partition. It now showed very slightly smaller than original, not sure if that was the problem. I couldn't resize the Dell utility to give a little more room. I was truly stuck.
Luckily, I had made a windows recovery image from windows 7 to try it out (I normally use IFW), and that got me back, apparently that copies both the Dell Utility and the Recovery partition. I use mbrwork to save embr's so I can go back to previous installs.
The fact that I couldn't recover everything bothers me, I've never had a problem with other partitions in the past. I would like to know if anyone know why, but how do I get rid of those Dell partitions. I suppose if they are really needed I could shrink them, is it a security thing. Thanks for any ideas

Re: Problem with Dell Laptop

Tue Jul 10, 2012 3:32 pm


Did you try a BCD Edit?

I've deleted the Dell Recovery partition on several computers. No problems.

Re: Problem with Dell Laptop

Tue Jul 10, 2012 5:49 pm

Thanks for replying, I'm not familiar with BCD Edit, what does that do and where do I find it. Had another problem, I deleted my Linux partitions and ran the 64 bit version from a live memory stick. When I tried to install it couldn't find any existing systems and saw the whole drive as free. Had no problem with same program 32 bit version - do you suppose it's a problem at their end!
Then I went to install the 32 bit Ubuntu from images, main install seemed ok, but when I went to restore the swap wasn't enough room. I find it disturbing that an image won't go back from whence it came. Is it something to do with alignment - what am I missing.
I've been using bootitng for years and never had a problem before this - could it be old age, hope not, I was starting to have fun with Linux.

Re: Problem with Dell Laptop

Tue Jul 10, 2012 6:56 pm

BCD Edit is in BIBM and BING. Just run the CD.

Re: Problem with Dell Laptop

Fri Jul 13, 2012 3:07 pm

I tried the Ubuntu 12.04 32 bit which I had previously installed with same problem. Then I loaded live install of Puppy. This is more informative but I'm thoroughly confused now. Puppy shows sda1, sda2, sda3, sda5, sda6. These display the contents of Dell Utility, Recover, Windows7 and two drives within my extended partition. There is enough free space beyond the extended partition for a linux install.
gparted from Puppy states unable to recognize partition table. The partition table looks to me the same as it always did using bootitng. What on earth is happening. How can Puppy show (and open) all the partitions if gparted can't read the partition table. How would I go about fixing it.
Post a reply