Format failed

User discussion and information resource forum for BootIt Bare Metal and BootIt UEFI

Format failed

Postby jacobsee » Wed Oct 30, 2019 1:17 pm

I'm having trouble formatting a large (4TB) USB drive to boot to IFU with the latest makedisk.exe from the bootit collection. I've been able to do it in the past (IFU 3.28), but now can't get it to work on 2 different identical drives.

I get through the entire setup process, select MBR/FAT32 with Default Geometry, and after the double-confirmation get an immediate 'Format Failed' error message.

I'm running makedisk on Win10 Pro, but have also tried it on a Win7 Pro box. Both are running as standard user (where I'm prompted for my Admin password to run makedisk), but I've also tried it as Admin.

Have tried several different short USB cables as 2 different drives.

Just went back and tried it again on my oldest version and it works!

Fails on 1.6.7.2 (bootit collection 1.12)
Fails on 1.6.6 (bootit collection 1.10)

Works on 1.6.3 (circa Aug, 2018)

Here are the config notes that I used for all tests:

PC Platform (UEFI)
Image for UEFI (GUI)
Traditional (customize)
Accept License Agreement
Default Video
1024x768
Disable Checkbox Selection (leave unchecked)
Global Geometry:
- Assume Same Target System
Misc Global Options:
- Completion Alarm
Adv Options: none
IFU.INI Options: Simple=1
Fill in license info from purchase email for BootIt Collection
Target (press USB+ to show the drive, because disks >64GB are hidden by default)
- Partition - MBR FAT32
- Geometry - Default
Confirm twice, writing takes about 5 seconds. About 5MB of files are written

Hopefully I'm just doing something careless. Any ideas what I can try next?
jacobsee
 
Posts: 12
Joined: Sat Jun 15, 2019 12:55 pm

Re: Format failed

Postby jacobsee » Fri Nov 01, 2019 8:54 am

Update: Both versions seem to complete ok for a small generic 4GB USB drive that ends up formatted as FAT.

Next I tried a larger 64GB flash drive (Corsair Voyager): format failed for newer version.

Then tried with old, 2018 version: "Unable to create directory efi" (had 2 existing partitions)

try again with all partitions deleted: same
jacobsee
 
Posts: 12
Joined: Sat Jun 15, 2019 12:55 pm

Re: Format failed

Postby jacobsee » Fri Nov 01, 2019 9:05 am

Is there a debug or troubleshooting log that I can turn on to try and get some more info about these makedisk failures?
jacobsee
 
Posts: 12
Joined: Sat Jun 15, 2019 12:55 pm

Re: Format failed

Postby jacobsee » Fri Nov 01, 2019 10:19 am

I disabled windows defender real-time protection, as well as controlled folder access, and now I'm getting it to work on the 64GB flash drive, but still not the 4TB USB drive.

One odd side note: I've reformatted this 64GB drive many times, but when I test booting to Image for UEFI 3.33, and I can do 'Validate a previous backup' and see a long list of old IFW backups that I did on this drive a long while ago.
jacobsee
 
Posts: 12
Joined: Sat Jun 15, 2019 12:55 pm

Re: Format failed

Postby jacobsee » Fri Nov 01, 2019 2:13 pm

I found a workaround - I just copied in the older version (1.6.3) of makefile.exe into the bootit_collection folder with the newest version of the biu, bibm, common folders and this works on my 4TB drive. Seems to point to a new bug in makefile.exe (fails on 1.6.7.2 and 1.6.6)
jacobsee
 
Posts: 12
Joined: Sat Jun 15, 2019 12:55 pm

Re: Format failed

Postby jacobsee » Fri Nov 01, 2019 2:25 pm

Note -- real-time protection gets reenabled on its own, and doesn't seem to be related, perhaps a coincidence earlier.
jacobsee
 
Posts: 12
Joined: Sat Jun 15, 2019 12:55 pm

Re: Format failed

Postby TeraByte Support » Sun Nov 03, 2019 12:28 pm

I was able to reproduce on a 3TiB (that had multiple partitions) so it will be checked out.

On 10/30/2019 12:17 PM, jacobsee wrote:
> I'm having trouble formatting a large (4TB) USB drive to boot to IFU with the latest makedisk.exe from the bootit collection.
TeraByte Support
 
Posts: 2964
Joined: Thu May 05, 2011 3:37 pm


Return to BootIt Collection