disabling Win10 'fast startup'

User discussion and information resource forum for BootIt Bare Metal and BootIt UEFI

disabling Win10 'fast startup'

Postby 30075 » Thu Jun 20, 2019 8:44 am

Hi,

After several years of not using BIBM, I had a PC die. I installed BIBM on another PC and added the dead PC's drive so I can switch between systems. It prompted me to disable Win10 'fast startup.' I read a bit about it, and it seems this only applies when you have your PC sleep or hibernate, which I do not do. Am I correct that I don't need to disable this in my case?

Thanks
30075
 
Posts: 35
Joined: Tue Apr 10, 2012 10:32 am

Re: disabling Win10 'fast startup'

Postby CyberSimian » Thu Jun 20, 2019 10:00 am

30075 wrote:
> it seems this only applies when you have your PC sleep or hibernate, which
> I do not do. Am I correct that I don't need to disable this in my case?

Unfortunately, you are NOT correct.

Microsoft in their wisdom decided in Windows 10 to make the "Shutdown" action cause hibernation, so that the system would restart more quickly on the next power up. To make "Shutdown" cause a true shutdown, you need to disable fast start. It is well hidden, so you will probably need to goggle to find out how to change the setting.

Note: there is nothing wrong with using hibernation, and I use it all of the time on my laptop. But you need to remember NOT to boot any other operating system that shares data partitions with the hibernated operating system, as this can result in corrupted file systems with loss of recently-changed data. For this reason, I want to know that when I shut down my system, it has REALLY shut down, and is not hibernating.

-- from CyberSimian in the UK
CyberSimian
 
Posts: 113
Joined: Wed Aug 10, 2016 5:13 am

Re: disabling Win10 'fast startup'

Postby 30075 » Thu Jun 20, 2019 10:32 am

thanks, I checked. The option wasn't showing up for me, but it turns out both installs had hibernation disabled entirely in the registry.
30075
 
Posts: 35
Joined: Tue Apr 10, 2012 10:32 am

Re: disabling Win10 'fast startup'

Postby DrTeeth » Sun Jun 23, 2019 7:42 am

On Thu, 20 Jun 2019 10:00:10 PDT, just as I was about to take a herb,
CyberSimian disturbed my reverie and wrote:

>But you need to remember NOT to boot any other operating system that shares data partitions with the hibernated operating system, as this can result in corrupted file systems with loss of recently-changed data.

TBU has a utility that forces the PC to boot the last hibernated OS.
It's called "bootnow". I do not use hibernation anymore since I moved
over to an SSD as regular boots are so fast. Used it for a while and
it was great!
--
Cheers,

DrT

** Amateurs built the Ark, but professionals built the Titanic.**
DrTeeth
 
Posts: 1256
Joined: Fri Aug 12, 2011 11:58 am

Re: disabling Win10 'fast startup'

Postby CyberSimian » Mon Jun 24, 2019 3:32 am

DrTeeth wrote:
> I do not use hibernation anymore since I moved
> over to an SSD as regular boots are so fast.

I use an SSD too, but the reason that I use hibernation is so that I can leave open the applications that I use frequently. I always have six command windows open, and usually also have a browser window open or minimised, and a "Spider Solitaire" window open or minimised (I have a quick game when, for some unknown reason, my home network decides to pause for one or two minutes, which it seems to do at least once a day).

-- from CyberSimian in the UK
CyberSimian
 
Posts: 113
Joined: Wed Aug 10, 2016 5:13 am

Re: disabling Win10 'fast startup'

Postby CyberSimian » Mon Jun 24, 2019 3:42 am

30075 wrote:
> The option wasn't showing up for me, but it turns out
> both installs had hibernation disabled entirely in the registry.

As I said, the "Fast Start" setting is well hidden, and Microsoft usually enable it again when a large update occurs.

I don't know the significance of hibernation being disabled in the registry, but I would not assume that it means that "Fast Start" is disabled. Pessimistically, I would assume that if "Fast Start" is enabled, it occurs even when hibernation is disabled. What does BIBM show on the "Properties" panel? If it still shows "Fast Start" is enabled, you run the risk of file system corruption in the circumstances that I described previously.

I have hibernation enabled, and "Fast Start" disabled, and BIBM shows that indeed "Fast Start" is disabled.

-- from CyberSimian in the UK
CyberSimian
 
Posts: 113
Joined: Wed Aug 10, 2016 5:13 am

Re: disabling Win10 'fast startup'

Postby DrTeeth » Mon Jun 24, 2019 4:52 am

On Mon, 24 Jun 2019 03:32:27 PDT, just as I was about to take a herb,
CyberSimian disturbed my reverie and wrote:

>I use an SSD too, but the reason that I use hibernation is so that I can leave open the applications that I use frequently.

Good point, well made.
--
Cheers,

DrT

** Amateurs built the Ark, but professionals built the Titanic.**
DrTeeth
 
Posts: 1256
Joined: Fri Aug 12, 2011 11:58 am

Re: disabling Win10 'fast startup'

Postby Ed Smith » Mon Jun 24, 2019 3:48 pm

I also use Hibernation and have Fast Start turned off. I dual boot too. I
have two versions of Windows I boot at times.
I have Fast Start turned off in each one.
When I want to boot to another, I shut down first.
Then reboot and select the other.
When done with that, shut down the computer before booting to the other one.
This was my data partition nor the two OS partitions ever get corrupted.

They did in the past before I started doing it this way.

You can use BareMetal to turn off Fast Start but off hand I don't remember
how.

But also do it by going to Cortana Search and type in "Control Panel".
Open "Control Panel".
Go to "Hardware and Sound".
Go to "Power Options".
On left click on "Choose what the power buttons do".
Under "Define power buttons and turn on password protection".
Click on the link for "Change settings that are currently unavailable".
Under "Shutdown Settings" take the check mark out for "Turn on Fast Start".

Like others say you might want to check the setting because sometimes a
major update turns it back on.
I haven't had that happen with the last two major upgrades of Windows 10.

Ed.

"CyberSimian" wrote in message news:17294@public.bootitbm...

30075 wrote:
> The option wasn't showing up for me, but it turns out
> both installs had hibernation disabled entirely in the registry.

As I said, the "Fast Start" setting is well hidden, and Microsoft usually
enable it again when a large update occurs.

I don't know the significance of hibernation being disabled in the registry,
but I would not assume that it means that "Fast Start" is disabled.
Pessimistically, I would assume that if "Fast Start" is enabled, it occurs
even when hibernation is disabled. What does BIBM show on the "Properties"
panel? If it still shows "Fast Start" is enabled, you run the risk of file
system corruption in the circumstances that I described previously.

I have hibernation enabled, and "Fast Start" disabled, and BIBM shows that
indeed "Fast Start" is disabled.

-- from CyberSimian in the UK

Ed Smith
 
Posts: 133
Joined: Thu Sep 01, 2011 11:14 am

Re: disabling Win10 'fast startup'

Postby Lizzie Almighty » Wed Jul 31, 2019 11:21 pm

Boot into BootIt BM.
Click Partition Work on the desktop.
Select the Windows 10 partition and then click the Properties button.
Click the Disable Fast Start button.
Lizzie Almighty
 
Posts: 1
Joined: Wed Jul 24, 2019 7:17 am


Return to BootIt Collection