Switch to full style
User discussion and information resource forum for BootIt Bare Metal.
Forum rules
Post a reply

Help, won't boot

Sun Apr 02, 2017 3:59 pm

Using BootIt BM, some years I had my computer dual booting Windows 7 and Windows 8 (updated to 8.1), but I never liked Windows 8 so I kept using the Windows 7 entry. During the free Windows 10 upgrade window I upgraded the Windows 8.1 partition to Windows 10, but continued to use Windows 7.

Today I decided to work with Windows 10. I was able to boot, and went through many Windows Updates (requiring many restarts). After one of these restarts I saw a message from BootIt BM about an unrecognized partition (which I ignored). Everything still seemed fine in Windows 10, and I rebooted manually several times.

But then I tried to reboot again into Windows 7. The computer will not boot (just a single beep). And now if I select Windows 10, the same thing happens.

What to do?

Re: Help, won't boot

Sun Apr 02, 2017 4:12 pm

Dave,

Have a look at Partition Work. Do you have an extra primary partition that wasn't present before? 450 MiB. Following the Win10 partition.

Are you limiting primaries? Or unlimited primaries?

Check your Boot Edits.

Re: Help, won't boot

Sun Apr 02, 2017 5:52 pm

Brian, thanks for the reply.

There are two 450 MiB partitions following the Win10 partition. They are both named "MBR Entry 1", and are of type "Windows RE". There is another Data partition after these two 450 MiB partitions.

Windows 7
Windows 10
MBR Entry 1
MBR Entry 1
Data

I use unlimited primaries.

Re: Help, won't boot

Sun Apr 02, 2017 5:58 pm

Dave, looks OK. How about your Boot Edits?

Re: Help, won't boot

Sun Apr 02, 2017 6:15 pm

I think the Boot Edits look OK, but what should I be looking for?

The Windows 7 entry boots to the Windows 7 partition, and the Windows 10 entry boots to the Windows 10 partition. Is this correct?

The only other thing is, the Windows 7 entry shows the Windows 10 partition as hidden, whereas the Windows 10 entry does not mention the Windows 7 partition. They both include the Data partition.

The "MBR entry" partitions are not mentioned anywhere.

It's so long ago that I set these things up....

Re: Help, won't boot

Sun Apr 02, 2017 6:30 pm

In Win7 Boot Edit, select the Win10 entry and click Clear.
In Win10 Boot Edit, click Fill to add both Recovery environments and Data.

Does it work now?

Re: Help, won't boot

Sun Apr 02, 2017 7:09 pm

No, but was I supposed to put the recovery environments in Win7 entry also? What I have now is:

Partitions:

Windows 7
Windows 10
MBR Entry 1
MBR Entry 1
Data

Windows 7 boot edit:

Windows 7, Data

Windows 10 boot edit :

Windows 10, Data, RE1, RE2

Still, either entry will boot.

Re: Help, won't boot

Sun Apr 02, 2017 7:29 pm

First, you should try adding the recovery partitions to the W10 boot entry one by one to see which is associated to it.

If that doesn't work, I'd delete the old W10 boot edit entry and redo it, not adding the recovery partitions, and give that a shot. Again, try adding the RP's one by one, if that doesn't work.

May be you need to have one of the recovery partitions as the boot target and not W10 at all.

If I had the OS install disks, I'd start over but that's neither here nor there ATM.

Re: Help, won't boot

Mon Apr 03, 2017 10:36 am

How will I find out which RE partition is associated with Win10?

Actually, I think they both are, because I started out with two 120000 MiB partitions, one for Windows 7, and one for Windows 8 (upgraded to Windows 10). But now the Windows 10 partition has size 119099; if I add in the two 450 MiB partitions I get 119999 MiB.

The history of my Windows 10 partition is that it started out with Windows Vista (x64), and then was upgraded to Windows 8, 8.1 and 10. Is it possible that to recovery partitions were collected along the way?

The thing that puzzles me is that Windows 10 was working perfectly, looking great on a 4K TV, until I tried to boot into Windows 7 again. Now it won't boot at all.

Re: Help, won't boot

Mon Apr 03, 2017 10:59 am

Ok, just had a look to refresh my memory. I was booted to my studio partition earlier and in the middle of recording so I was reluctant to re-boot and check then.

Let's forget about the other "created" partitions and get W10 to boot. Open Partition Work and double-click the entries one by one. Here, for each partition, it will say whether it's bootable or non-bootable. If the Windows 10 says non-bootable, go back to Boot Edit, open the W10 partition and make sure the W10 part is still selected and the drive it's on is correct.

It's sounding more like after the upgrade, you forgot to re-enable BIBM before booting to anything and Windows Boot Manager may have taken over. If that's the case it can be fixed. Try what I said above and if there's still no joy we'll tackle Windows Boot Manager. There's a KB article on it and how to fix it, IIRC.
Post a reply