Why CHKDSK in 7 after using 8.1 ?

User discussion and information resource forum for BootIt Bare Metal.

Re: Why CHKDSK in 7 after using 8.1 ?

Postby TeraByte Support » Thu Feb 27, 2014 8:23 pm

partition work can turn it off for you if it was on. anyway, have you
rebooted to win7 from win7. if it chkdsk each type you just need to fix the
registry.


"Patosan" wrote in message news:7641@public.bootitbm...

OK guys I had become so frustrated by the only advice being turn off Fast
Startup via Power Options, when it wasn't there as an option for me. So I
re-installed 8.1 again ! This time before turning off hibernation or
changing the power plan to High Performance I could see the option ... Yahoo
!! So I disabled it there and restarted into win7, alas still getting
CHKDSK. So now we know that after killing Hibernation the Fast Startup
option in Power Options disappears, as does Hibernation check box.

Then I tried a normal SD and power up, rather than "restart" but the same
result ... CHKDSK. In all the checks I've experienced over the last few days
there haven't been any errors found. There hasn't been any data loss or
corruption, just a long checking delay. I then went and did my usual cmd>
powercfg -h off hibernation kill and still getting CHKDSK.

So in summary I have tried :
1. Unchecking Fast Startup in Power Options
2. Killing Hibernation via cmd/ powercfg -h off (as admin)
3. Used balanced and High Performance power plans
4. Turn_Off_Fast_Startup.bat file for registry fix
5. msFixIt Stop Hibernation prog
6. checked Fast Startup "off" in BIBM partition properties
7. Triedclosing8.1 via both Shutdown & Restart modes

Where to next ?

TeraByte Support
 
Posts: 2324
Joined: Thu May 05, 2011 3:37 pm

Re: Why CHKDSK in 7 after using 8.1 ?

Postby Patosan » Fri Feb 28, 2014 12:14 am

TeraByte Support wrote:
> partition work can turn it off for you if it was on. anyway, have you
> rebooted to win7 from win7. if it chkdsk each type you just need to fix
> the
> registry.

Trouble is only going from 8.1 to 7, any of the 7 I have installed. From 7 to another 7 or same 7 is fine, from 7 to 8.1 is fine also. Thus the CHLDSK seems to be caused by 8.1 Fast Startup even though its turned off in 8.1 & BIBM properties !
Patosan
 
Posts: 43
Joined: Fri Dec 30, 2011 6:23 pm

Re: Why CHKDSK in 7 after using 8.1 ?

Postby Eric » Fri Feb 28, 2014 2:31 am

And which drive letters are those Win7 chkdsk checking? Are they checking C: or the letters corresponding to the Win8.1?
Can you also verify FROM Win8.1 (and not from BIBM - I already saw cases where the hiberboot was enabled from Win8.1, but BIBM show them as disable) if the hiberboot is really disable?
(You can follow the method explain above, or directly check under the registry the value HiberbootEnabled under HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Power).

Win8.1 might not shut down correctly, or does not flush disk.
Eric
 
Posts: 95
Joined: Mon Sep 05, 2011 11:53 am

Re: Why CHKDSK in 7 after using 8.1 ?

Postby Patosan » Fri Feb 28, 2014 3:57 pm

Eric wrote:
> And which drive letters are those Win7 chkdsk checking? Are they checking
> C: or the letters corresponding to the Win8.1?
> Can you also verify FROM Win8.1 (and not from BIBM - I already saw cases
> where the hiberboot was enabled from Win8.1, but BIBM show them as disable)
> if the hiberboot is really disable?
> (You can follow the method explain above, or directly check under the
> registry the value HiberbootEnabled under
> HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Power).

Firstly the drive letters - a good idea - CHKDSK is always and only checking the spinning HDD which has the shared media and data files. None of the ssd os or shared portable software partitions are ever checked. What does this tell us ?

Next I looked in the registry - thank you for an excellent piece of advice - I checked in both ContolSet & ControlSet001. In both cases the HiberbootEnabled values were "0" which is the setting for Disable. So I couldn't change anything ... but it was good to check it.
Advice link : http://www.trishtech.com/2013/07/how-to ... windows-8/

Finally I double checked that the CHKDSK is occurring after both "Shutdown" & "Restart", which it IS. I did this check by touching nothing in 8.1 after booting except to turn off, i.e. I didn't access and data at all. But CHKDSK is still happening.

This is becoming quite a project ... I hope that some others can learn something from this along the way.
Patosan
 
Posts: 43
Joined: Fri Dec 30, 2011 6:23 pm

Re: Why CHKDSK in 7 after using 8.1 ?

Postby TeraByte Support » Fri Feb 28, 2014 4:26 pm

Try this to see if it's not downgrading the logfile on shutdown or reboot as
it should be...

To turn off the behavior of NTFS upgrading the log file structure and
version number to 2.0 upon a mount of a NTFS volume in Windows 8, please
follow the below steps. Note that this registry key does not persist the
upgrade behavior to the volume, it only changes the behavior of the NTFS
driver on the local system.

1.. Open the Start Screen by pressing the Windows Key or by navigating to
the top right corner of your screen, summoning the Charms bar, and clicking
the Windows icon.
2.. Type in “regedit.exe”, and launch the application, allowing it to make
changes to your computer if prompted.
3.. Navigate using the tree on the left pane to:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem\
4.. Look for a REG_DWORD entry with the name “NtfsDisableLfsUpgrade”. If
it does not exist, create it.
5.. Changing the value to a non-zero value (we recommend a value of 1)
will prevent NTFS from upgrading the Logfile structure and version number to
2.0 upon a volume mount. Resetting the value to zero will return the system
to the default behavior to upgrade the Logfile structure and version number
to 2.0 upon a volume mount.
6.. Close the Registry Editor and perform a system Restart (not Shutdown)
to downgrade all mounted NTFS volumes to a log file structure and version
number compatible with prior versions of Windows. Upon the next boot of
Windows 8, NTFS will no longer upgrade the log file structure and version
number to 2.0 if the above key was set to a non-zero value.

"Patosan" wrote in message news:7650@public.bootitbm...

Eric wrote:
> And which drive letters are those Win7 chkdsk checking? Are they checking
> C: or the letters corresponding to the Win8.1?
> Can you also verify FROM Win8.1 (and not from BIBM - I already saw cases
> where the hiberboot was enabled from Win8.1, but BIBM show them as
> disable)
> if the hiberboot is really disable?
> (You can follow the method explain above, or directly check under the
> registry the value HiberbootEnabled under
> HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Power).

Firstly the drive letters - a good idea - CHKDSK is always and only checking
the spinning HDD which has the shared media and data files. None of the ssd
os or shared portable software partitions are ever checked. What does this
tell us ?

Next I looked in the registry - thank you for an excellent piece of advice -
I checked in both ContolSet & ControlSet001. In both cases the
HiberbootEnabled values were "0" which is the setting for Disable. So I
couldn't change anything ... but it was good to check it.
Advice link :

[
http://www.trishtech.com/2013/07/how-to ... windows-8/
](http://www.trishtech.com/2013/07/how-to-disable-hiberboot-in-windows-8/)

Finally I double checked that the CHKDSK is occurring after both "Shutdown"
& "Restart", which it IS. I did this check by touching nothing in 8.1 after
booting except to turn off, i.e. I didn't access and data at all. But CHKDSK
is still happening.

This is becoming quite a project ... I hope that some others can learn
something from this along the way.

TeraByte Support
 
Posts: 2324
Joined: Thu May 05, 2011 3:37 pm

Re: Why CHKDSK in 7 after using 8.1 ?

Postby Patosan » Fri Feb 28, 2014 7:06 pm

TeraByte Support wrote:
> Try this to see if it's not downgrading the logfile on shutdown or reboot
> as it should be...
>
> To turn off the behavior of NTFS upgrading the log file structure and
> version number to 2.0 upon a mount of a NTFS volume in Windows 8, please
> follow the below steps. Note that this registry key does not persist the
> upgrade behavior to the volume, it only changes the behavior of the NTFS
> driver on the local system.

There was no NtfsDisableLfsUpgrade key so I created one as suggested and made value 1.
Note there was NtfsDisableLfsDowngrade value 0
also there was NtfsDisableLastAccessUpdate value 1
There is no change in behavior though, it's still performing CHKDSK, I tried Restart the later Shutdown.

As a note I thought I should check if the hdd is also Primary partitions UNlimited as for the os ssd.
It is, ssd & hdd both not limited, so there's no chance that was somehow causing the trouble.
The quest continues.
Patosan
 
Posts: 43
Joined: Fri Dec 30, 2011 6:23 pm

Re: Why CHKDSK in 7 after using 8.1 ?

Postby oakeny » Sat Mar 01, 2014 10:41 pm

I see you have had a number of suggestions and no luck so far.

I once had the same trouble with a drive in my XP machine.
It would start chkdsk every time, and find no errors.

The problem turned out to be the setting of something called the "dirty
bit" which windows xp checks on startup, and this bit had been set to
true. Apparently Windows 7 does the same.

In my case it seems the dirty bit had been set when there was a temporary problem with a drive cable connection. The dirty bit isn't automatically cleared when the problem goes away, so user intervention is necessary.

I don't have a copy of the solution on hand, but it turned out to be fairly
simple to fix.

So, if you wish to try something else, try searching for "dirty bit chkdsk windows 7" in google and you will find a number of sources on how to fix this
particular error.

However, it may not be the same problem you are experiencing.

Cheers, and good luck

John S
oakeny
 
Posts: 22
Joined: Wed Sep 07, 2011 10:12 pm

Previous

Return to BootIt Bare Metal