WinPE GPT MFT Corruption and Fix

User discussion and information resource forum for BootIt Bare Metal and BootIt UEFI

WinPE GPT MFT Corruption and Fix

Postby rich071 » Tue Mar 12, 2013 6:51 pm

The following is based on Intel AHCI drivers in a Terabyte WinPE. This is to pass on what I found as a solution and Terabyte is NOT responsible for the Intel drivers inside a WAIK installation or in Windows installation that causes the MFT corruption to a GPT drive.

Before posting, I had searched the forum for GPT problems. The ones I found were not related to this. I would like to hear if anyone has had similar issues with their GPT drives.

To begin, as I stated in am earlier post, after installing a GPT data drive, 3TB drive, I received MFT corruption when installing a new Windows 7 partition. A work around to that problem is turning the GPT drive off in the bios, install Windows 7 and update the Intel drivers AHCI drivers to and lastly re-enable the GPT drive in the bios to avoid any MFT corruption. This time, I have included the versions of the drivers listed.

I just now built a WinPE using, the tools in and downloading the WAIK for Windows 7. I also upgraded the WAIK to the latest SP1. The build went smoothly and I am really impressed with the TB Launcher and the other goodies that were added.

As a test, after booting into the TB WinPE without doing anything, I restarted the machine back into Windows 7 with the GPT drive still enabled. The MFT corruption came back again because of the Intel drivers in the WinPE. Inside Windows 7, chkdsk fixed the MFT corruption.

I identified the initial WinPE drivers as Intel version dated 11/20/2010. I used the DISM utility to update the drivers in the WIM to dated 11/19/12 and it fixed the MFT problem when rebooting, like the above test. After doing a test backup and validation inside WinPE and validated again within Windows 7, I am happy to say that all went well with no problems.

FYI, I originally setup the drive, changed it to GPT, and formatted inside Bootit BM. I see two partitions, Microsoft's reserved partition and one data partition that is the rest of the drive. I am assuming this is the best way to set the drive up, correct?

If possible, I would like to be able to remove or hide the GPT drive without removing it from the bios, when needed, in the Menu Edit Item in each boot item. From the Menu Edit Item's, here is what I found for each drive type.

EMBR partition - Can be cleared or hidden with the appropriate tab, Clear or Hide
MBR drives - Can be hidden from the Volumes tab, select partition
GPT drives - All options are grayed out

I realize this may not be option with a GPT drive, but you don't know if you don't ask.

Posts: 24
Joined: Sun Jun 17, 2012 10:14 am

Re: WinPE GPT MFT Corruption and Fix

Postby Brian K » Wed Mar 13, 2013 12:32 am

I don't think you can install Win7 to a non-UEFI GPT drive. Does your motherboard support UEFI?
Brian K
Posts: 1595
Joined: Thu Aug 11, 2011 6:11 pm
Location: NSW, Australia

Re: WinPE GPT MFT Corruption and Fix

Postby rich071 » Wed Mar 13, 2013 3:41 am

No, I didn't try to install Windows 7 to the GPT drive and no, my motherboard is not UEFI compatible. I installed it as a data only drive, as I knew my system would not support the booting from the drive. I purchased the drive because Bootit BM would see the entire drive as a data drive on MBR system.

I ran into the driver issue by accident. I had already updated the Intel storage drivers for Windows XP x64 before purchasing the drive. XP x64 was seeing the drive fine. When reinstalling Windows 7, and I failed to hide it in the bios, the MFT corruption happened immediately after Windows rebooted the first time after installing. My first thought was a driver issue. I immediately went to Intel's website and found the drivers I needed and it has worked fine since.

After starting this thread, I did a little research to see when and what Intel storage versions support GPT drives. Keep in mind, version 8.x was on the Windows 7 SP1 installation disc. Version was in the WAIK WIM with SP1. With the links, below, version 10.1, is the earliest version of the drivers needed for the AHCI support with no Raid support. Raid support is included in the latest drivers, My mistake in referencing, above. Sometimes, I can't read my own hand writing. But that's another topic. :oops:

The links below indicate what others have experinced with the older drivers. Fortunately, mine was minor compared to others. With the Bootit BM setup and Windows XP x64 working nicely, it had to be drivers. ... ive-issue/

In case anyone needs them, the link below, is for the latest drivers. I used the the iata_enu.exe for Windows 7 and added the drivers, in the to the WinPE with the DISM command. ... iid=dc_rss

Posts: 24
Joined: Sun Jun 17, 2012 10:14 am

Re: WinPE GPT MFT Corruption and Fix

Postby DrTeeth » Thu Mar 14, 2013 1:55 am

If you ever need Intel's later drivers that have passed MSofts testing (WQHL ?) but not officially released let me know. I always use the latest possible.

Posts: 1232
Joined: Fri Aug 12, 2011 11:58 am

Return to BootIt Collection