GRUB problems

User discussion and information resource forum for BootIt Bare Metal and BootIt UEFI
Post Reply
RFSndrs
Posts: 61
Joined: Mon Sep 12, 2011 2:42 pm

GRUB problems

Post by RFSndrs »

I am using BUI on a Dell inspiration 3000 laptop. I have Windows 10, Linux Mint 18, and Linux Mint 20 installed on my boot drive (a 250GB SSD NVMe drive). I use BUI to handle the EFI partition.

I had some minor problems with my Linux Mint 20 installation and wanted to install a fresh copy and keep my same data and programs. So I imaged my Mint20 install and tried my fresh install and hosed it up. I re-imaged my old Mint20 from the BUI image and tried again. I screwed it up again. So I re-imaged my old Mint20 which then booted into the “grub>” cursor. I tried several times and then re-imaged again. Same thing. I then tried re-imaging and older copy of Mint20 and it booted into the same “grub>” cursor. Is there a way to reinstall grub2 for an EFI system? I tried the reinstall that is in the knowledge base, but it is for MBR and didn’t work. The reason I’m asking this forum is that I use BUI to handle the EFI loading. BTW, Linux Mint 18 and Windows 10 still boot okay.

Also, if I were to clean my boot drive and start all over, would it be possible to install Mint20 from scratch, install my Mint 20 programs, and then reinstall my Windows 10 from the image I have. How would I do the EMS for the Windows part?



Thanks,
Bob S
Brian K
Posts: 1861
Joined: Fri Aug 12, 2011 1:11 am
Location: NSW, Australia

Re: GRUB problems

Post by Brian K »

Bob,

Do you have an image of the ESP taken before the fresh Mint20 install? If so you could replace your current ubuntu.xxx with the good one from the image.
RFSndrs
Posts: 61
Joined: Mon Sep 12, 2011 2:42 pm

Re: GRUB problems

Post by RFSndrs »

Yes, I do. Will try that. Thanks!
RFSndrs
Posts: 61
Joined: Mon Sep 12, 2011 2:42 pm

Re: GRUB problems

Post by RFSndrs »

Tried to do that but couldn't figure out how to copy ubuntu.002. BUI didn't have a copy function that I could find.
Would also like an answer to the second part of my original question, or isn't it possible?
Brian K
Posts: 1861
Joined: Fri Aug 12, 2011 1:11 am
Location: NSW, Australia

Re: GRUB problems

Post by Brian K »

Bob, extract ubuntu.002 from your image. Use tbexplo.tbs in BIU to copy/paste ubuntu.002 into C:\EFI\ and overwrite the existing file.

Or you could just restore two partitions from an image when everything was working properly. Restore the ESP and Mint20 partitions.
RFSndrs
Posts: 61
Joined: Mon Sep 12, 2011 2:42 pm

Re: GRUB problems

Post by RFSndrs »

Restored the ESP and it worked. Thanks..... I guess there is no way to restore an image without the proper ESP?
Brian K
Posts: 1861
Joined: Fri Aug 12, 2011 1:11 am
Location: NSW, Australia

Re: GRUB problems

Post by Brian K »

You must have had an issue with both partitions. Grub is in the ESP. If the ESP is OK then only the OS partition needs to be restored.
Post Reply