{"id":461,"date":"2011-02-09T23:26:00","date_gmt":"2011-02-10T07:26:00","guid":{"rendered":"https:\/\/kb.terabyteunlimited.com\/kb-articles\/error-vss-snapshot-creation-failed\/"},"modified":"2022-10-17T10:16:14","modified_gmt":"2022-10-17T17:16:14","slug":"error-vss-snapshot-creation-failed","status":"publish","type":"lsvr_kba","link":"https:\/\/www.terabyteunlimited.com\/kb\/kb-articles\/error-vss-snapshot-creation-failed\/","title":{"rendered":"Error: VSS Snapshot Creation Failed"},"content":{"rendered":"<p><strong><font color=\"#ff5500\">Problem:<\/font><\/strong> <\/p>\r\n  <p>Image for Windows is configured to use VSS instead of PHYLock to obtain the snapshot of the drive. The VSS snapshot fails and reports an error in the IFW.log file. Two examples are shown below:<\/p>\r\n  <blockquote style=\"MARGIN-RIGHT: 0px\" dir=\"ltr\">\r\n    <p><font color=\"#ff0000\">Error: VSS Snapshot Creation Failed (1h)<\/font><\/p>\r\n    <p><font color=\"#ff0000\">Error: VSS Snapshot Creation Failed (80042308h)<\/font><br \/>&nbsp;&nbsp;<font color=\"#777777\"><em>(<strong>80042308h:<\/strong> VSS Object not found - VolumeName does not correspond to an existing volume)<\/em><\/font> <\/p>\r\n  <\/blockquote>\r\n  <p>Errors will also be reported by VSS in the Windows Event Log. There may be multiple events logged for a single failure (e.g. <strong>Event ID 12293<\/strong>, <strong>8193<\/strong>, <strong>8194<\/strong>, <strong>4001<\/strong>, etc.).<\/p>\r\n  <blockquote>\r\n    <p><font color=\"#ff0000\">Source: VSS, Event ID: 12293<br \/>Volume Shadow Copy Service error: Error calling a routine on a Shadow Copy Provider {GUID}. Routine details EndPrepareSnapshots ({GUID}) [hr = 0x80042302, A Volume Shadow Copy Service component encountered an unexpected error.].<\/font><\/p>\r\n    <p><font color=\"#ff0000\">Source: VSS, Event ID: 12293<br \/>Volume Shadow Copy Service error: Error calling a routine on a Shadow Copy Provider {GUID}. Routine details EndPrepareSnapshots ({GUID}) [hr = 0x80070015, The device is not ready.].<\/font><\/p>\r\n    <p><font color=\"#ff0000\">Source: VSS, Event ID: 8194<br \/>Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface. hr = 0x80070005, Access is denied. This is often caused by incorrect security settings in either the writer or requester process.<\/font><\/p>\r\n    <p><font color=\"#ff0000\">Source: VSS, Event ID: 8193<br \/>Volume Shadow Copy Service error: Unexpected error calling routine Cannot find anymore diff area candidates for volume &#92;&#92;?&#92;Volume{GUID}&#92; [0]. hr = 0x8000ffff, Catastrophic failure<\/font><\/p>\r\n    <p><font color=\"#ff0000\">Source: VSS, Event ID: 4001<br \/>Volume Shadow Copy Service error: Cannot find diff areas for creating shadow copies. Add at least one NTFS drive to the system with enough free space. The free space needed is at least 32 Mb for each volume to be shadow copied.<\/font><\/p>\r\n  <\/blockquote>\r\n  <p>Note that error details will vary.<\/p>\r\n  <p><strong><font color=\"#ff5500\">Solution:<\/font><\/strong> <\/p>\r\n  <p><font color=\"#005858\"><strong>Error is reported along with Event ID 12293<\/strong><\/font><\/p>\r\n  <p>This error can be caused by one of the partitions included in the backup being set <em>offline<\/em>. For example, the System Reserved partition of Windows 7 or Windows Server 2008 R2, which is usually not assigned a drive letter, has been changed from <em>online<\/em> to <em>offline<\/em>. Windows will normally automatically bring this type of partition online. However, if automount is disabled or a third-party program has affected the system, it's possible the partition will remain in the offline state.<\/p>\r\n  <p>To check or change the state of <strong>automount<\/strong>, start an Administrator Command Prompt, then type <font color=\"#0000aa\"><strong>DISKPART<\/strong><\/font> and press Enter. Run the applicable commands at the DISKPART prompt:<\/p>\r\n  <ul>\r\n    <li>To check the state of <strong>automount<\/strong>: Type <font color=\"#0000aa\"><strong>automount<\/strong><\/font> and press Enter. The current state will be displayed.<\/li>\r\n    <li>To enable <strong>automount<\/strong>: Type <font color=\"#0000aa\"><strong>automount enable<\/strong><\/font> and press Enter. <\/li>\r\n    <li>To disable <strong>automount<\/strong>: Type <font color=\"#0000aa\"><strong>automount disable<\/strong><\/font> and press Enter.<\/li>\r\n  <\/ul>\r\n  <p>In most cases, you will want to have automount enabled. <\/p>\r\n  <p>Note: If automount has been disabled for a specific reason (e.g. an installed program requirement), the partition can be brought online manually before performing the backup. It will return to the offline state when the system restarts. <\/p>\r\n  <p>To view or change the online status of a partition, run the applicable commands at the DISKPART prompt:<\/p>\r\n  <ul>\r\n    <li>Type <font color=\"#0000aa\"><strong>list volume<\/strong><\/font> and press Enter. This will list the volumes (partitions) on the system. Make note of the volume number assigned to the partition in question. The <em>Info<\/em> column should indicate if the partition is offline.<\/li>\r\n    <li>Select the volume (<em>Volume 1<\/em> will be used in this example): Type <strong><font color=\"#0000aa\">select volume 1<\/font><\/strong> and press Enter.<\/li>\r\n    <li>To view volume details: Type <strong><font color=\"#0000aa\">detail volume<\/font><\/strong> and press Enter.<\/li>\r\n    <li>To set the partition <strong>online<\/strong>: Type <strong><font color=\"#0000aa\">online volume<\/font><\/strong> and press Enter.<\/li>\r\n    <li>To set the partition <strong>offline<\/strong>: Type <strong><font color=\"#0000aa\">offline volume<\/font><\/strong> and press Enter.<\/li>\r\n    <li>To exit DISKPART: Type <strong><font color=\"#0000aa\">exit<\/font><\/strong> and press Enter.<\/li>\r\n  <\/ul>\r\n  <p>Once the partition is online you can attempt to create the backup again.<\/p>\r\n  <p><font color=\"#005858\"><strong>Error is reported along with Event ID 4001<\/strong><\/font><\/p>\r\n  <p>See KB article <a href=\"https:\/\/www.terabyteunlimited.com\/kb\/?p=639\" target=\"_blank\" rel=\"noopener\">Backup Fails with VSS Event 4001<\/a>.<\/p>\r\n  <p><strong><font color=\"#005858\">Other Solutions:<\/font><\/strong><\/p>\r\n  <p>The following list contains other possible causes for this problem and steps to resolve them:<\/p>\r\n  <ul>\r\n    <li><font color=\"#005858\"><strong>File system errors<\/strong><\/font><br \/>Snapshot creation may fail if file system errors are encountered. You can perform error checking on a&nbsp;volume by&nbsp;running <strong>chkdsk \/f<\/strong> or <strong>chkdsk \/r<\/strong> on it. <br \/><br \/>For example, to check the C: drive, open an Administrator Command Prompt and run the following command:<br \/><font color=\"#0000aa\"><strong>chkdsk c: \/f<\/strong><\/font><br \/><br \/>Make sure to check each partition that is being backed up.<br \/><br \/>For help on running a file system check in Windows directly from Explorer, please see: <a href=\"http:\/\/windows.microsoft.com\/en-US\/windows7\/Check-a-drive-for-errors\" target=\"_blank\" rel=\"noopener\"><br \/>http:\/\/windows.microsoft.com\/en-US\/windows7\/Check-a-drive-for-errors<\/a><br \/><br \/><\/li>\r\n    <li><font color=\"#005858\"><strong>Source volume being backed up is not formatted NTFS<\/strong><\/font><br \/>VSS only supports NTFS formatted volumes. Use PHYLock instead of VSS if the volume is not formatted NTFS. As an example, a Dell utility partition being included in the backup can cause VSS to fail. Exclude the partition from the backup.<br \/><br \/><\/li>\r\n    <li><font color=\"#005858\"><strong>Multiple simultaneous use of the VSS provider<\/strong><\/font><br \/>Ensure the system is not running another service using the VSS provider at the same time as the backup is to be run. The VSS provider may not support multiple snapshots&nbsp;being created at the same time.<br \/><br \/><\/li>\r\n    <li><font color=\"#005858\"><strong>Insufficient free space on volume<\/strong><\/font><br \/>Depending on the version of Windows being used and the size of volume, there may need to be 300MB to 1GB of free space available on the volume.&nbsp;Make more space by deleting unnecessary files and\/or moving&nbsp;files to another drive.<br \/><br \/><\/li>\r\n    <li><font color=\"#005858\"><strong>High disk activity<\/strong><\/font><br \/>High disk activity at the time of the backup may cause&nbsp;VSS to fail. Try running the backup during times of low or normal disk activity.<br \/><br \/><\/li>\r\n    <li><font color=\"#005858\"><strong>System is in &quot;setup mode&quot;<\/strong><\/font><br \/>Ensure the system isn't in setup mode by checking the following registry key:<br \/><font color=\"#0000aa\">HKEY_LOCAL_MACHINE&#92;SYSTEM&#92;Setup<\/font><br \/><br \/>The values <strong>SystemSetupInProgress<\/strong> and <strong>UpgradeInProgress<\/strong> should be&nbsp;set to <strong>0<\/strong> (zero) or&nbsp;not exist.<br \/><br \/><\/li>\r\n    <li><font color=\"#005858\"><strong>Conflict with third-party program or service<\/strong><\/font><br \/>If the problem started after&nbsp;installing a new program or service, try uninstalling&nbsp;the new program or service to resolve the problem.<br \/><br \/><\/li>\r\n    <li><font color=\"#005858\"><strong>Non-Microsoft VSS providers<\/strong><\/font><br \/>Providers that are created by parties other than Microsoft may cause problems. <br \/><br \/>To view the list of&nbsp;installed providers,&nbsp;open&nbsp;an Administrator Command Prompt (right click command prompt and choose run as administrator) and run the following command:<br \/><font color=\"#0000aa\"><strong>vssadmin list providers<\/strong><\/font><br \/><br \/>Consider uninstalling the software that installed any of the third party providers you find&nbsp;and try the backup again.<br \/><br \/><\/li>\r\n  <\/ul><hr \/>\r\n  <p>If none of these solutions have solved the problem, try searching the Microsoft site for the error number you received.<br \/><br \/>Google example: <font color=\"#0000aa\">site:microsoft.com vss 80042308<\/font><\/p>\r\n","protected":false},"excerpt":{"rendered":"<p>Problem: Image for Windows is configured to use VSS instead of PHYLock to obtain the snapshot of the drive. The VSS snapshot fails and reports an error in the IFW.log file. Two examples are shown below: Error: VSS Snapshot Creation Failed (1h) Error: VSS Snapshot Creation Failed (80042308h)&nbsp;&nbsp;(80042308h: VSS Object not found &#8211; VolumeName does [&hellip;]<\/p>\n","protected":false},"author":5,"featured_media":0,"comment_status":"closed","ping_status":"closed","template":"","meta":{"footnotes":""},"lsvr_kba_cat":[1790],"lsvr_kba_tag":[2121],"class_list":["post-461","lsvr_kba","type-lsvr_kba","status-publish","hentry","lsvr_kba_cat-problem-solving-image-for-windows","lsvr_kba_tag-image-for-windows"],"_links":{"self":[{"href":"https:\/\/www.terabyteunlimited.com\/kb\/wp-json\/wp\/v2\/lsvr_kba\/461","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/www.terabyteunlimited.com\/kb\/wp-json\/wp\/v2\/lsvr_kba"}],"about":[{"href":"https:\/\/www.terabyteunlimited.com\/kb\/wp-json\/wp\/v2\/types\/lsvr_kba"}],"author":[{"embeddable":true,"href":"https:\/\/www.terabyteunlimited.com\/kb\/wp-json\/wp\/v2\/users\/5"}],"replies":[{"embeddable":true,"href":"https:\/\/www.terabyteunlimited.com\/kb\/wp-json\/wp\/v2\/comments?post=461"}],"version-history":[{"count":5,"href":"https:\/\/www.terabyteunlimited.com\/kb\/wp-json\/wp\/v2\/lsvr_kba\/461\/revisions"}],"predecessor-version":[{"id":7104,"href":"https:\/\/www.terabyteunlimited.com\/kb\/wp-json\/wp\/v2\/lsvr_kba\/461\/revisions\/7104"}],"wp:attachment":[{"href":"https:\/\/www.terabyteunlimited.com\/kb\/wp-json\/wp\/v2\/media?parent=461"}],"wp:term":[{"taxonomy":"lsvr_kba_cat","embeddable":true,"href":"https:\/\/www.terabyteunlimited.com\/kb\/wp-json\/wp\/v2\/lsvr_kba_cat?post=461"},{"taxonomy":"lsvr_kba_tag","embeddable":true,"href":"https:\/\/www.terabyteunlimited.com\/kb\/wp-json\/wp\/v2\/lsvr_kba_tag?post=461"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}