Install fail not liking partition

User discussion and information resource forum for BootIt Bare Metal.

Install fail not liking partition

Postby grege » Tue Jan 14, 2014 2:21 pm

Hi, surprised to have trouble using the newer version, did use older versions ok many years ago when it was a lot less streamlined and I was used to editing partition tables manually! Just purchased / downloaded 15 jan 14. (Saw some passwords I didn't need, did I get the wrong one?)

Win7 32bit, Vaio laptop, internal disk. Has on it:
recovery partition done by sony
os install NTFS with following under it using win7 inbuilt gui
Data partition done by win 7 GUI when I set it up
2nd data partition by win 7 GUI when I set it up
Another partition NTFS put there by win 7 GUI preparing for dual boot, but no data on it at all so can be canned if needed.

Whole purpose is to clone os to a second bootable copy for testing and swap to in case of virus etc problems, as I have done many times on XP with these older tools.

Created a bootable flash drive, set bios to allow boot of that first. BIBM comes up and runs.

NO MATTER how many options or ways I try it (manual, auto shared), I cannot get it to install to the hard drive, says cannot find partition or create it. I've changed disk to EMBR, when I allow manual selection of the partition, it does not show the setup button until I go into Properties button and back out (bizarre!) but when shown the Setup is always greyed. Tried FAt32 100mb formatted partition, also bootit embr type.

Only thing I've not done yet is allow more than 4 primaries, as I dont want yet to drop possibility of using Win7 tools. Surely with all the options I have, one of the install approached should work automatically or manually!!!! This was a lot easier with the old versions methinks, and it just worked...
Seems like I'm not getting helpful error messages or missing something obvious. Help appreciated..
grege
 
Posts: 3
Joined: Tue Jan 14, 2014 1:53 pm

Re: Install fail not liking partition

Postby Brian K » Tue Jan 14, 2014 8:53 pm

grege wrote:

> Win7 32bit, Vaio laptop, internal disk. Has on it:
> recovery partition done by sony
> os install NTFS with following under it using win7 inbuilt gui
> Data partition done by win 7 GUI when I set it up
> 2nd data partition by win 7 GUI when I set it up
> Another partition NTFS put there by win 7 GUI preparing for dual boot,

How many Primary Partitions do you have on the HD?
Brian K
 
Posts: 1157
Joined: Thu Aug 11, 2011 6:11 pm

Re: Install fail not liking partition

Postby grege » Wed Jan 15, 2014 4:52 am

According to Win7disk mgmt:
3 primaries 1 extended and one recovery(not either of other types)
The one I have been nominating to install to is a primary, 100MB had as fat 32 and BIBM boot at various stages.

Primaries are c: OS, another 100M System disk of W7 install, 100M I created after fail of auto setup of BIBM to point to as manual install.

Logical drives are D: W: data drives I did within Win 7 at install time.

Seems likely it has a problem with this causing it to fail, and I guess I just give up on the limit primaries approach. Interesting the Win7 Disk mgmt is only thing that tells me which are primary, BIBM makes no statement of type I can find...
grege
 
Posts: 3
Joined: Tue Jan 14, 2014 1:53 pm

Re: Install fail not liking partition

Postby grege » Wed Jan 15, 2014 5:49 am

OK so tried allowing more than 4 primaries, still exactly the same problem, won't either create or allow me to give it a partition to use.

Aggh, seems like there is some other problem like the boot too high on the disk or something totally random / buggy.

Is it Vaio rescue partition, or some other gotcha? Can I get an older version, is this one broken? Do I give up and ask for my $ back, try another product?

Win7 disk mgmt screendump attached showing config without a manual partition created.

If I get desperate I may go back to the old ways of noting the partition table entries (start and end cyl) of the Vaio rescue, delete them from the partition table but of course leave the data there, so I can enable again later. Or see if XOSL is still around. But don't reckon this should be this hard !!
Attachments
disklayout.jpg
disklayout.jpg (123.51 KiB) Viewed 2223 times
grege
 
Posts: 3
Joined: Tue Jan 14, 2014 1:53 pm

Re: Install fail not liking partition

Postby TeraByte Support(PP) » Wed Jan 15, 2014 11:34 am

There are already four primary partitions so you would have to allow unlimited (more than four) to get the extra partition. You have three primary and one extended (the extended partition container uses a primary partition table slot).

BIBM shows logical partitions (volumes) indented in their extended partition. They are also labeled "Volume" (primary partitions are labeled "Partition").

When you boot to BIBM to install it are you doing these steps:

1) Click OK to install.
2) Click Yes to enable support for more than 4 primary partitions.
3) Click Yes to have setup choose the partition for you.
4) Click Yes to install to a dedicated partition.
5) Click OK to install.

Otherwise, you would need to remove one of the four primary partitions so there's a free slot available for the BIBM partition (none of your existing partitions are supported for BIBM's installation).
Paul Purviance
TeraByte Support
TeraByte Support(PP)
 
Posts: 1089
Joined: Thu Aug 11, 2011 5:51 pm


Return to BootIt Bare Metal

cron