2nd added OS broke Sleep Mode in 1st OS (Windows 7 1st)

User discussion and information resource forum for BootIt Bare Metal.

2nd added OS broke Sleep Mode in 1st OS (Windows 7 1st)

Postby Tom_Wells » Fri Nov 30, 2012 10:21 am

BootIt BM (& Image) did a great job of letting me move Windows 7 Ultimate to a new 2TB hard drive (HD) without much study. I was able to edit the Windows 7 Boot Configuration Data and change all of the HD0 referenced to HD1 such that the System Reserved boot partition now points to its new partition on HD1. Windows 7 seemed very happy including SLEEP MODE.

I was then able to install Windows Server 2012 Standard on the older HD0 drive (actually both drives are RAID 1 pairs but appear as HD0 & HD1 via the BIOS). => BootIT BM lets me choose either operating system (OS) at startup or restart as intended. So I made lots of progress forward but now Windows 7 Ultimate will not go into Sleep mode for more than a few seconds. In other words, the Windows 7 Ultimate OS tries to SLEEP but wakes right back up.

Since I believe that the 2nd OS install broke Sleep mode on the 1st OS, I became concerned when I noted that the System Configuration >> Boot displays the 2nd OS when running the 1st OS ! => In other words, running Windows 7, the System Configuration >> Boot form displays "Windows Server 2012 (D:\Windows) : Default OS".

Furthermore, when Windows 7 installed, it created a hidden System Reserved partition on HD1. Likewise, Windows Server 2012 also created a boot partition but it was NOT hidden and consequently it was assigned a drive letter. Hmm... Very suspicious! (But perhaps irrelevant ?)

So I downloaded and installed EasyBCD 2.2 and fussed around with the System Reserved boot configuration data to no avail, tried hiding the 2nd System Reserved boot partition (for Windows Server) to no avail and searched the internet for clues to no avail.

Any Thoughts ? (I'd rather put the system to SLEEP than always have to shut down.)

Thanks, Tom
Tom_Wells
 
Posts: 4
Joined: Fri Nov 30, 2012 9:20 am

Re: 2nd added OS broke Sleep Mode in 1st OS (Windows 7 1st)

Postby TeraByte Support(PP) » Fri Nov 30, 2012 10:38 am

Does the Event Log show the reason the computer wakes up?
Paul Purviance
TeraByte Support
TeraByte Support(PP)
 
Posts: 1087
Joined: Thu Aug 11, 2011 5:51 pm

Re: 2nd added OS broke Sleep Mode in 1st OS (Windows 7 1st)

Postby Tom_Wells » Sat Dec 01, 2012 1:31 pm

I looked at the event log before I posted and didn't see anything suspicious. Assuming that the Date / Time clock is in very close sync with the Event Viewer Date / Time stamp, I think that I'm seeing 16 "Pnp or Power Management operations..." from the DriverFrameworks-UserMode AFTER hitting the sleep button. Three seconds later, I see a DNS Client Events warning in the log about a name resolution timeout that looks harmless enough. (I created a Custom View for everything covering the last hour then sort by Date and TIme.)

I also tried going back to my first backup of the Windows 7 Ultimate OS and then to the first restore point to no avail. I'm still thinking that installing the 2nd OS caused the problem but I don't really know that for sure because I don't test Win 7 SLEEP mode after every system change (to either OS). (=> I was not surprised to see that Windows Server 2012 lacks a sleep mode.)

So I'll probably try and get hibernate mode to work again next (even though this PC has 16GB of RAM with 16GB more on order while matching RAM can still be purchased). => I don't play computer games. Instead, I experiment with software. The current goal is to be able to run virtual Desktops on the server (not that I really need to do so)....
_____________________________________________________________________
Tom_Wells
 
Posts: 4
Joined: Fri Nov 30, 2012 9:20 am

Re: 2nd added OS broke Sleep Mode in 1st OS (Windows 7 1st)

Postby TeraByte Support(PP) » Sat Dec 01, 2012 1:58 pm

After waking up my computer, the first entry I see in the System section is Kernel-General (Event ID 1) saying the time was changed. Then, a few seconds later, a Power-Troubleshooter entry (Event ID 1), which states that the system has resumed from sleep. It also states the reason it woke up (in my case, Device -USB Root Hub).

Do you see those types of entries?
Paul Purviance
TeraByte Support
TeraByte Support(PP)
 
Posts: 1087
Joined: Thu Aug 11, 2011 5:51 pm

Re: 2nd added OS broke Sleep Mode in 1st OS (Windows 7 1st)

Postby Tom_Wells » Sat Dec 01, 2012 2:59 pm

Thank you for comparing my events to yours. You have shown me that this problematic PC is failing to go to sleep. Looking at a happy to sleep Windows 7 Pro PC, I see a Microsoft Windows security auditing logoff following the last "Pnp or Power Management operations..." and the ID 1 Event 12 events later. Hmm... the last "Pnp or Power Management operations..." is with regard to a USB device than can be disabled....
Tom_Wells
 
Posts: 4
Joined: Fri Nov 30, 2012 9:20 am

Re: 2nd added OS broke Sleep Mode in 1st OS (Windows 7 1st)

Postby Tom_Wells » Sun Dec 02, 2012 11:19 am

Windows 7 Ultimate will Sleep now apparently because I'm NOT using BootIT BM as the effective Boot Manager (the BootIT BM partition is still on HD0). Here's how BootIT BM was overridden;

1.) Formatted the Windows 7 Ultimate Partition using the Windows 7 Setup CD-ROM and reinstalled Windows.

2.) Tested the very minimal Windows 7 Ultimate install. => It will go to sleep and recover.

3.) Noted that the BootIT BM did NOT appear. Instead a Windows Boot Manager now lets me choose Windows 7 OR Windows Server 2012. Apparently the MS Setup software saw/found Windows Server 2012 and decided to simply add Windows 7 to the menu.

4.) Verified that Windows Server still works and backed up the minimal Windows 7 Ultimate OS (just in case).

5.) Decided to test the newly installed Windows Boot Manager with the with the most recent FULL / LOADED Windows 7 Ultimate OS backup (in case that makes a difference). So I loaded the OS partition via Image for DOS and now the Windows 7 Ultimate boot will SLEEP! (Yeah, no need to install gobs of software into the minimal OS and frequently check SLEEP mode.)

6.) EasyBCD 2.2 shows that this (32GB PC as of this AM) is using the Windows Boot Manager installed by Windows Server on HD0 instead of the Windows Boot Manager installed by Windows 7 on HD1

Never did figure out how to get Hibernate mode to work but SLEEP mode is better / faster (& safe enough because of a large UPS).

So did adding Windows Server 2012 somehow break the Windows 7 OS Sleep Mode? (BootIT BM was installed first and I believe that Windows 7 Ultimate was able to sleep before the server OS was installed. I recall being quiet surprised when Windows 7 wouldn't sleep.)

Regardless, both OSs appear to be working well at the moment (until I break something...)

Thanks for your concern,
Tom
Tom_Wells
 
Posts: 4
Joined: Fri Nov 30, 2012 9:20 am


Return to BootIt Bare Metal

cron