Computer won't boot after restore

User discussion and information resource forum for BootIt Bare Metal.

Computer won't boot after restore

Postby hfletcher » Sun Sep 18, 2016 8:49 am

I made an image of an Asus computer running Windows 10. The computer was originally a Win 7 computer that progressed to Win 10 through free upgrades. The multi-file image was made with the IFD 3.02 included with my newly acquired BIBM. The image had six partitions 0.TBI through 5.TBI. The partitions were: RE tools (NTSF 800MiB), a System partition which IFD said was active (FAT-32 260 MiB), a Microsoft Reserved Partition (GPT Entry 128MiB), Win10 (NTFS 153600 MiB), Data (NTFS 780744 MiB), and Recovery Image (NTFS 18336 MiB).
When I tried to restore this image IFD said it could not install any more partitions when I reached the fifth partition. After I installed BBIM and allowed more than four primaries I completed the restoration process, but the computer wouldn't boot. BIBM said no operating system could be found. And later it said the configured boot partition was not found.
Prior to installing the multi disc backup, I started to wipe the drive but that was going to take too long so I cancelled the wipe and installed on the free space (no partitions left). I did not create new partitions, nor format the drive since I figured IFD would do all that.
What a nightmare! If IFD is cloning the drive, doesn't it recreate the partitions, boot sectors and set active the proper partition? All that data was part of the disc IFD cloned. In other words, if the computer booted fine previously, why won't it's clone boot?
The computer is dead now with no recovery environment available. How do I undo this mess? Would this restore have worked if I had made a single file image? Please excuse my ignorance and thanks for any help.
hfletcher
 
Posts: 12
Joined: Sat Sep 28, 2013 11:40 am

Re: Computer won't boot after restore

Postby Brian K » Sun Sep 18, 2016 2:15 pm

hfletcher,

See http://www.terabyteunlimited.com/kb/article.php?id=572

Did you change your BIOS from UEFI to Legacy/MBR and disable Secure Boot so BIBM would boot? It looks like your Win10 system is in UEFI mode.
Brian K
 
Posts: 1174
Joined: Thu Aug 11, 2011 6:11 pm

Re: Computer won't boot after restore

Postby CyberSimian » Sun Sep 18, 2016 2:23 pm

hfletcher wrote:
> The image had six partitions 0.TBI through 5.TBI.

I think this means that the disk was partitioned with a GPT (Guid Partition Table). Only a GPT allows more than 4 primary partitions to be visible concurrently.

> When I tried to restore this image IFD said it could not install any more
> partitions when I reached the fifth partition.

This means that the disk had been switched to MBR (Master Boot Record), which allows only 4 primary partitions on a disk. So the GPT image could not be restored in full.

> After I installed BBIM and
> allowed more than four primaries I completed the restoration process, but
> the computer wouldn't boot.

Allowing more than 4 primaries means that you converted from MBR to EMBR (Extended Master Boot Record). An EMBR allows you to define many more primary partitions, BUT ONLY 4 CAN BE VISIBLE AT ANY ONE TIME. So although you were able to restore all 6 partitions, only 4 of them would have been visible.

If you want to use BIBM in a multiboot scenario, you have explicitly to convert your GPT disk to EMBR, using the procedure described in the relevant Terabyte Knowledgebase article. I did this recently with my new Lenovo laptop, and this conversion was successful. HOWEVER, you end up losing some of the partitions, because 6 cannot fit into 4. In my view, the recovery partitions are of little value if you are using BIBM to backup your partitions, so I did not mind losing them. In your case, you could discard all partitions apart from WINDOWS and DATA. But only AFTER you have converted the system from GPT to EMBR.

The question is: why did BIBM not restore the partition images as GPT? I don't know the answer to that, and will have to leave that to one of the Terabyte Support guys to explain.

-- from CyberSimian in the UK
CyberSimian
 
Posts: 47
Joined: Wed Aug 10, 2016 5:13 am

Re: Computer won't boot after restore

Postby TeraByte Support » Sun Sep 18, 2016 3:38 pm

you shouldn't use multi-file unless you understand what it does, which is
creates a separate image per partition, like it was a single partition
backup.

So now your files have individual partitions and will be restored
accordingly (as just a single partition). You'd have to manually set the
disk type as you want it, then assuming gpt, you have to restore the efi
system first, then your others (if you have the update boot partition option
available you should check that).

If it wasn't GPT to begin with (should be several reference already to how
to do this), you'd restore the boot partition first with set active and
restore first track, then your other partitions with the "update boot
partition" enabled (set active disabled).


"hfletcher" wrote in message news:12540@public.bootitbm...

I made an image of an Asus computer running Windows 10. The computer was
originally a Win 7 computer that progressed to Win 10 through free upgrades.
The multi-file image was made ...

TeraByte Support
 
Posts: 2310
Joined: Thu May 05, 2011 3:37 pm

Re: Computer won't boot after restore

Postby Brian K » Tue Sep 20, 2016 6:06 pm

hfletcher,

All OK with this issue now?
Brian K
 
Posts: 1174
Joined: Thu Aug 11, 2011 6:11 pm


Return to BootIt Bare Metal