CENTOS 7 Installation - BIBM sees entire disks

User discussion and information resource forum for BootIt Bare Metal.

CENTOS 7 Installation - BIBM sees entire disks

Postby ohaya » Tue Aug 23, 2016 4:29 pm

Hi,

This is a continuation of an earlier thread I had in the "Technology" section. Now that I figured out why I couldn't burn the DVD, I want to find out about the problem I'm having when trying to setup the CENTOS 7 as dual-boot with Windows 10.

As I mentioned in that earlier thread, I created a partition on the hard drive (HD1) for CENTOS, and I made a boot item with only that "CENTOS" partition on HD1.

Then I unplug the DVD player and reboot to BIBM, and I select the CENTOS boot item.

That give me the popup saying to reboot at that point, so I plug the DVD player in (which has the CENTOS installation) and reboot.

The CENTOS installer starts running and i have to select the Troubleshooting and then install with basic screen and then i get a page where I can configure things, including the disks.

I go to the disk configuration and it shows both the NVMe SSD (HD0) and the 1TB HD (HD1), with their full sizes instead of the 8GB CENTOS partition I setup on the HD1.

Shouldn't BIBM be showing only that CENTOS partition?

I've tried the above both with swap enabled and disabled and it behaves the same.

Pls advise.

Thanks,
Jim
ohaya
 
Posts: 174
Joined: Fri Jan 06, 2012 4:40 pm

Re: CENTOS 7 Installation - BIBM sees entire disks

Postby TeraByte Support » Tue Aug 23, 2016 10:10 pm

Follow that tutorial on installing CentOS, you may wan to disconnect the W10
drive during your install, Provided the boot item has the partition
configured for it. it should show up in the mbr details after booting the
boot item.

"ohaya" wrote in message news:12282@public.bootitbm...

Hi,

This is a continuation of an earlier thread I had in the "Technology"
section. Now that I figured out why I couldn't burn the DVD, I want to find
out about the problem I'm having when trying to setup the CENTOS 7 as
dual-boot with Windows 10.

As I mentioned in that earlier thread, I created a partition on the hard
drive (HD1) for CENTOS, and I made a boot item with only that "CENTOS"
partition on HD1.

Then I unplug the DVD player and reboot to BIBM, and I select the CENTOS
boot item.

That give me the popup saying to reboot at that point, so I plug the DVD
player in (which has the CENTOS installation) and reboot.

The CENTOS installer starts running and i have to select the Troubleshooting
and then install with basic screen and then i get a page where I can
configure things, including the disks.

I go to the disk configuration and it shows both the NVMe SSD (HD0) and the
1TB HD (HD1), with their full sizes instead of the 8GB CENTOS partition I
setup on the HD1.

Shouldn't BIBM be showing only that CENTOS partition?

I've tried the above both with swap enabled and disabled and it behaves the
same.

Pls advise.

Thanks,
Jim

TeraByte Support
 
Posts: 2313
Joined: Thu May 05, 2011 3:37 pm

Re: CENTOS 7 Installation - BIBM sees entire disks

Postby ohaya » Fri Aug 26, 2016 7:12 pm

For the record, I was able to get the CENTOS installed and multi-booted with BIBM.

Actually, I should correct that... I changed to installing CENTOS 6, hoping that it was better behaved wrt Grub, but it wasn't, and I was install CENTOS 6 to that partition I made, but I couldn't boot to it.

I ended up having to install Grub to the first partition manually and have to make a new grub.conf, and then I was able to get it to boot:

default=0
timeout=5
splashimage=(hd1,0)/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.32-642.el6.x86_64)
root (hd1,0)
kernel /boot/vmlinuz-2.6.32-642.el6.x86_64 ro root=/dev/sda1
initrd /boot/initramfs-2.6.32-642.el6.x86_64.img

Note the "hd1", because the partition was on the 1TB hard driver, which was "HD1", the 2nd drive.
ohaya
 
Posts: 174
Joined: Fri Jan 06, 2012 4:40 pm


Return to BootIt Bare Metal

cron