IFW terribly slow from TBWinRE bootable USB

User discussion and information resource forum for Image products.

IFW terribly slow from TBWinRE bootable USB

Postby PsychBiller » Tue Jun 28, 2016 4:50 pm

I'm used to running IFL from a bootable USB. Perfectly happy with the length of time to backup and validate a full system image.

Then I switched to using IFW from a TBWinRE bootable USB because I have installed Windows 10 and BitLocker. I am using VSS, not PhyLock. Process Priority is set to High. The encrypted drive is unlocked, and I use the Read from Volume option. I am omitting the page and hibernation files. Speed is set to Enhanced A.

I just started a backup on a system with a 256GB SSD that's maybe 10% full, and IFW says it will take 11 HOURS to a USB 3.0 external hard drive directly connected?

I know that IFW is slower than IFL, but 11 hours is beyond believable. I prefer a full image, but taking a system out of commission for an entire day to do so is unacceptable.

What can I do about this? Thank you for your ideas.
PsychBiller
 
Posts: 38
Joined: Sun Aug 05, 2012 9:45 am

Re: IFW terribly slow from TBWinRE bootable USB

Postby TeraByte Support(PP) » Tue Jun 28, 2016 6:08 pm

What does the IFW.LOG file show?

Note that VSS doesn't work in normal TBWinRE builds (base WinPE doesn't support it). Are you doing something custom? Otherwise, I assume you mean you have that option enabled, but the log would show it wasn't used.

Does it make a difference if you leave the priority at the default? It's not usually necessary to change it and nothing else is running in WinPE.

How long does a validation take from an image on the USB drive? You could compare that with the same validation in Windows. This would help determine if the port is functioning at USB 3 speeds (or close to it).

Try different USB 3 ports if you have any. Many systems have multiple sets of ports and are run by different controllers. Some may work better in WinPE than others.
Paul Purviance
TeraByte Support
TeraByte Support(PP)
 
Posts: 1100
Joined: Thu Aug 11, 2011 5:51 pm

Re: IFW terribly slow from TBWinRE bootable USB

Postby PsychBiller » Tue Jun 28, 2016 6:29 pm

Paul,

I guess I'm defaulting to PhyLock then. Is there a way to get VSS somehow? The service is there, but it is stopped. Starting it first, then starting IFW doesn't help.

Not doing anything custom. I didn't create a log because I canceled the backup.
PsychBiller
 
Posts: 38
Joined: Sun Aug 05, 2012 9:45 am

Re: IFW terribly slow from TBWinRE bootable USB

Postby TeraByte Support(PP) » Tue Jun 28, 2016 6:47 pm

PHYLock isn't used either. The disks/partitions can be locked normally since Windows isn't running. It isn't necessary to use VSS since "Read from Volume" will access the unlocked partition.

The log may show something helpful. Note that you would have to copy it out to save it since it would be lost when you reboot.

I would try some of the suggested tests and see if anything shows up. Sometimes it's a simple matter of using a different port. You could also check the BIOS USB settings since sometimes those can affect the speed of the ports. For example, the BIOS may delay USB 3 activation.
Paul Purviance
TeraByte Support
TeraByte Support(PP)
 
Posts: 1100
Joined: Thu Aug 11, 2011 5:51 pm


Return to Image for DOS/Linux/Windows