Robocopy

User discussion forum for items related to technology in general.

Robocopy

Postby Brian K » Mon Mar 18, 2013 2:01 pm

This page made me study Robocopy again as the switches were very helpful...

http://www.terabyteunlimited.com/kb/article.php?id=554

I used Robocopy to copy the Win8 My Pictures library to an external HD. (The library was D:\Users\Brian\Pictures. It had been moved from the C: drive) The copy was successful (Robocopy log) but the target folder had disappeared from the external HD. "Showing" protected operating system files made the folder visible. Is this normal behaviour when copying a Win8 library? How can I stop the backup being hidden?
Brian K
 
Posts: 1157
Joined: Thu Aug 11, 2011 6:11 pm

Re: Robocopy

Postby AlanD » Mon Mar 18, 2013 3:08 pm

On 2013-03-18 5:01 PM, Brian K wrote:
> This page made me study Robocopy again as the switches were very helpful...
>
> [
> http://www.terabyteunlimited.com/kb/article.php?id=554
> ](http://www.terabyteunlimited.com/kb/article.php?id=554)
>
> I used Robocopy to copy the Win8 My Pictures library to an external HD. (The library was D:\Users\Brian\Pictures. It had been moved from the C: drive) The copy was successful (Robocopy log) but the target folder had disappeared from the external HD. "Showing" protected operating system files made the folder visible. Is this normal behaviour when copying a Win8 library? How can I stop the backup being hidden?
>
>
Interesting, Brian

I never heard of using RoboCopy for that.

Coincidentally, I just within past hour finished moving all of my music
files (5664 flac files, 616 folders) and changing library pointers, from
default C:\Libraries\Music\My Music to E:\Music\My Music (a new 1TB
internal drive).
Total of about 90GB move. All went very well, nothing else to do,
except for telling my CD Ripper and My Music Jukebox where to look.
I did the move from the library, not from music actual folder locations.
Simple cut and paste.

My image time was increasing (1 HR, 25 Min last night)as I continue to
rip more of my CD collection, so something needed doing.

AlanD


AlanD
 
Posts: 192
Joined: Sat Sep 17, 2011 9:45 am

Re: Robocopy

Postby Brian K » Mon Mar 18, 2013 7:46 pm

Alan, I was only doing this as a backup.
Brian K
 
Posts: 1157
Joined: Thu Aug 11, 2011 6:11 pm

Re: Robocopy

Postby Brian K » Thu Mar 21, 2013 7:21 pm

I tried this on another computer and the target folder wasn't hidden. Oh well.
Brian K
 
Posts: 1157
Joined: Thu Aug 11, 2011 6:11 pm

Re: Robocopy

Postby AlanD » Tue May 28, 2013 8:46 am

On 2013-03-18 5:01 PM, Brian K wrote:
> This page made me study Robocopy again as the switches were very helpful...
>
> [
> http://www.terabyteunlimited.com/kb/article.php?id=554
> ](http://www.terabyteunlimited.com/kb/article.php?id=554)
>
> I used Robocopy to copy the Win8 My Pictures library to an external HD. (The library was D:\Users\Brian\Pictures. It had been moved from the C: drive) The copy was successful (Robocopy log) but the target folder had disappeared from the external HD. "Showing" protected operating system files made the folder visible. Is this normal behaviour when copying a Win8 library? How can I stop the backup being hidden?
>
>
Brian,

I got around to doing some reading regards Robocopy, and then digested a
lot of info on XXCopy.

Tried them both to see how they handled gathering all JPG files from C:
drive and placing in one folder.

XXCopy is far and away the the most efficient and trouble-free, plus it
provides many, many more options. Not to mention quite a bit of online
help and examples.

Really comprehensive program.

AlanD
AlanD
 
Posts: 192
Joined: Sat Sep 17, 2011 9:45 am


Return to Technology