Page 1 of 2

IFL 3.10 won't run in 64bit OS

PostPosted: Mon Sep 11, 2017 11:47 am
by powhyfo
I have been running IFL 2.60 for years in my Linux box - both in the 32bit & 64 bit versions. I upgraded to IFL 3.10 when I got a new PC and2.60 would not recognize my main HDD anymore.
I downloaded the 3.10 trial version, burned a CD and checked - sure enough, 3.10 sees the hardware just fine & is faster than 2.60 so I bought it.
Installed it, it won't run. Apparently it needs some 32 bit libraries!?! It runs on a bootable CD, but not on a 64 bit HDD?

After install I get this message:
IMPORTANT: On 64-bit distributions, 32-bit shared libraries will need to be installed to run IFL (GUI). Please see the KB article at the link below:
http://www.terabyteunlimited.com/kb/article.php?id=566

Well, that link is no help at all since the download-install links/commands return a 'Couldn't find package' error. It's 2017, why can't TeraByte write a 64 bit program?

Re: IFL 3.10 won't run in 64bit OS

PostPosted: Mon Sep 11, 2017 12:30 pm
by TeraByte Support(PP)
Which Linux are you installing in (distro, version, kernel)?

Also, which version of IFL are you using (CUI/GUI)?

Re: IFL 3.10 won't run in 64bit OS

PostPosted: Mon Sep 11, 2017 1:19 pm
by powhyfo
PCLOS 64 2017.7
KDE5
QT 5.9.1
Frame 5.37.0

IFL = CUI

Re: IFL 3.10 won't run in 64bit OS

PostPosted: Tue Sep 26, 2017 3:01 pm
by powhyfo
I have managed to get it to the point it says "error while loading shared libraries: libXft.so.2: cannot open shared object file: No such file or directory" when trying to run an installed (bought and paid for) version 3.10........

Re: IFL 3.10 won't run in 64bit OS

PostPosted: Tue Sep 26, 2017 10:06 pm
by TeraByte Support
apparently the packages are at
https://ftp.nluug.nl/os/Linux/distr/uplos/32bit/RPMS.updates/

your best bet is to ask in http://www.pclinuxos.com/forum/index.php how to
install the 32bit shared libraries. If you can at least get ncurses on
there, you should be close to being able to use the CUI version.


"powhyfo" wrote in message news:14219@public.image...

I have managed to get it to the point it says "error while loading shared
libraries: libXft.so.2: cannot open shared object file: No such file or
directory" when trying to run an installed (bought and paid for) version
3.10........


Re: IFL 3.10 won't run in 64bit OS

PostPosted: Wed Sep 27, 2017 12:02 am
by TeraByte Support(PP)
I was able to get both the IFL CUI and GUI versions running using the Uplos packages (there is no longer a 32-bit version of PCLOS developed). However, some packages were also uninstalled in the process, which could possibly cause issues if you need those.

I installed the packages directly from Synaptic. First, add the new repository. Start Synaptic, click on the Settings menu, then Repositories. Click the New button and type in the URI, Distribution and Section(s) values:
URI: http://ftp.nluug.nl/os/Linux/distr/
Distribution: uplos/32bit
Section(s): updates

Next, click OK and then click Reload. Search for "ncurses" and mark the following packages to install: libncursesw5.32bit, ncurses-extraterms.32bit. Then search for "xft2" and mark libxft2.32bit to install. Note that a few more packages will be selected automatically (including ia32-libs) and several will be removed. Click the Apply button to install the marked packages. (Note: If you only need IFL GUI to run you can just select to install the libxft2.32bit package.)

Re: IFL 3.10 won't run in 64bit OS

PostPosted: Sun Oct 22, 2017 1:38 pm
by powhyfo
Uplos is a third party attempt to keep the old 32 bit PCLOS distro alive. You cannot mix 32 and 64 bit libraries.

Re: IFL 3.10 won't run in 64bit OS

PostPosted: Sun Oct 22, 2017 1:53 pm
by TAC109
wrote:
> Uplos is a third party attempt to keep the old 32 bit PCLOS distro alive.
> You cannot mix 32 and 64 bit libraries.

Are you using the 64bit version of IFL?


Re: IFL 3.10 won't run in 64bit OS

PostPosted: Sun Oct 22, 2017 2:39 pm
by TeraByte Support
the binary is x86 even on the IFL x64 kernel boot disk. Just needs the
shared libraries for 32-bit applications.

"Tom Cole" wrote in message news:14271@public.image...


wrote:
> Uplos is a third party attempt to keep the old 32 bit PCLOS distro alive.
> You cannot mix 32 and 64 bit libraries.

Are you using the 64bit version of IFL?


Re: IFL 3.10 won't run in 64bit OS

PostPosted: Wed Nov 08, 2017 8:31 am
by powhyfo
If I install the 32bit versions from 2015 as you describe above Synaptic wants to remove the 2017 64 bit versions as well as some of the apps like mylivecd and mylivegtk.

Thanks for trying, but it appears IFL will not run in my 64bit distro so if I want to use it I will have to boot from a CD. I should have tried installing before buying.