Page 1 of 2

Byte-for-Byte verify fails using IFW but not IFL

PostPosted: Sun Mar 26, 2017 10:54 pm
by Skyglider
Running IFW v2.99 on Win10. System drive is a Samsung 120GB SSD with 22GB free. Doing a backup of the SSD using IFW with byte-for-byte verify, fails using VSS or Pythlock.

But when I use IFL booted from a USB flash drive, backup of the same SSD using byte-for-byte verify completes successfully. Using IFL, I was also able to do a successful backup of my 1.5TB hard drive that has 630GB of data on it, using byte-for-byte verify.

Since IFL can do successful backups using byte-for-byte verification, I think that verifies that my hardware is fine. So why can't IFW do successful backups using byte-for-byte verify? Is there a setting that I need to make in IFW?

Re: Byte-for-Byte verify fails using IFW but not IFL

PostPosted: Sat Apr 01, 2017 9:11 pm
by TeraByte Support
Presuming you're using a recent 3.x version, what's the log say for the
entire session?

Also see http://www.terabyteunlimited.com/kb/article.php?id=151


"Skyglider" wrote in message news:13507@public.image...

Running IFW v2.99 on Win10. System drive is a Samsung 120GB SSD with 22GB
free. Doing a backup of the SSD using IFW with byte-for-byte verify, fails
using VSS or Pythlock.

But when I use IFL booted from a USB flash drive, backup of the same SSD
using byte-for-byte verify completes successfully. Using IFL, I was also
able to do a successful backup of my 1.5TB hard drive that has 630GB of data
on it, using byte-for-byte verify.

Since IFL can do successful backups using byte-for-byte verification, I
think that verifies that my hardware is fine. So why can't IFW do
successful backups using byte-for-byte verify? Is there a setting that I
need to make in IFW?


Re: Byte-for-Byte verify fails using IFW but not IFL

PostPosted: Fri Apr 07, 2017 3:19 pm
by Skyglider
TeraByte Support wrote:
> Presuming you're using a recent 3.x version, what's the log say for the
> entire session?
> Also see http://www.terabyteunlimited.com/kb/article.php?id=151

Thanks for the help. As stated in my original post, I'm using IFW v2.99.

Regarding the link provided, what I don't understand is why Byte-for-byte validation fails using IFW using VSS or Pythlock, but runs successfully using IFL booted from a USB flash drive. Seems that since IFL can do successful byte-for-byte validations, my hardware must be OK. Appears that IFW cannot handle something changing while windows is running.
----------

EDIT:
I found the log for IFW v2.99 that failed:

[3/25/2017 7:32:44 PM] Image for Windows (x64) 2.99-00
[3/25/2017 7:32:44 PM] Starting ...
imagew64.exe /b /d:w0 /f:"N:\IFW Backups\XPS-8900 Backups\170325 Entire SSD Win10" /vb
[3/25/2017 7:32:44 PM] PHYLock is waiting for drive writing to stop ...
[3/25/2017 7:32:55 PM] PHYLock using drive C:
[3/25/2017 7:32:55 PM] PHYLock Started
[3/25/2017 7:32:55 PM] PHYLock Using Disk
[3/25/2017 7:32:55 PM] PHYLock version 12
[3/25/2017 7:32:55 PM] Backup: Drive 0 ESP Partition (01) 200 MiB FAT-32
[3/25/2017 7:32:55 PM] To: N:\IFW Backups\XPS-8900 Backups\170325 Entire SSD Win10.TBI
[3/25/2017 7:32:56 PM] INFO: Total Sectors:409600 Total Allocated:59200
[3/25/2017 7:32:56 PM] INFO: 59200 Sector(s) backed up
[3/25/2017 7:32:56 PM] Backup: Drive 0 Microsoft reserv Partition (02) 16 MiB GPT Entry
[3/25/2017 7:32:56 PM] To: N:\IFW Backups\XPS-8900 Backups\170325 Entire SSD Win10.TBI
[3/25/2017 7:32:56 PM] INFO: Total Sectors:32768 Total Allocated:32768
[3/25/2017 7:32:56 PM] INFO: 32768 Sector(s) backed up
[3/25/2017 7:32:56 PM] Backup: Drive 0 (C:) OS Partition (03) 113799 MiB NTFS
[3/25/2017 7:32:56 PM] To: N:\IFW Backups\XPS-8900 Backups\170325 Entire SSD Win10.TBI
[3/25/2017 7:45:06 PM] INFO: Total Sectors:233060360 Total Allocated:185320376
[3/25/2017 7:45:06 PM] INFO: 171457192 Sector(s) backed up
[3/25/2017 7:45:06 PM] Backup: Drive 0 WINRETOOLS Partition (04) 455 MiB NTFS
[3/25/2017 7:45:06 PM] To: N:\IFW Backups\XPS-8900 Backups\170325 Entire SSD Win10.TBI
[3/25/2017 7:45:10 PM] INFO: Total Sectors:932776 Total Allocated:678768
[3/25/2017 7:45:10 PM] INFO: 678768 Sector(s) backed up
[3/25/2017 7:45:18 PM] Validating: ESP Partition (01) 200 MiB FAT-32
[3/25/2017 7:45:18 PM] From: N:\IFW Backups\XPS-8900 Backups\170325 Entire SSD Win10.TBI
[3/25/2017 7:45:19 PM] Validating: Microsoft reserv Partition (02) 16 MiB GPT Entry
[3/25/2017 7:45:19 PM] From: N:\IFW Backups\XPS-8900 Backups\170325 Entire SSD Win10.TBI
[3/25/2017 7:45:19 PM] Validating: OS Partition (03) 113799 MiB NTFS
[3/25/2017 7:45:19 PM] From: N:\IFW Backups\XPS-8900 Backups\170325 Entire SSD Win10.TBI
[3/25/2017 7:46:27 PM] Byte-for-Byte failure at LBA 17064118 offset 0 (11264)
[3/25/2017 7:46:27 PM] Deleting incomplete or failed backup.
[3/25/2017 7:46:27 PM] Deleting N:\IFW Backups\XPS-8900 Backups\170325 Entire SSD Win10.TBI
[3/25/2017 7:46:27 PM] Operation Completed with Error Code 200
[3/25/2017 7:46:27 PM] Byte-for-Byte comparison failed
[3/25/2017 9:45:17 PM] Stop

Hope this helps.

Re: Byte-for-Byte verify fails using IFW but not IFL

PostPosted: Wed Apr 12, 2017 10:10 am
by Skyglider
Any ideas?

Re: Byte-for-Byte verify fails using IFW but not IFL

PostPosted: Wed Apr 12, 2017 1:57 pm
by mashedmitten
All I can think of is the time will be different from the image to the validation, no?

Re: Byte-for-Byte verify fails using IFW but not IFL

PostPosted: Wed Apr 12, 2017 11:13 pm
by TeraByte Support(PP)
What model is the Samsung SSD? If it doesn't support Deterministic TRIM then it can cause problems with validating.

Re: Byte-for-Byte verify fails using IFW but not IFL

PostPosted: Thu Apr 13, 2017 11:30 am
by Skyglider
mashedmitten wrote:
> All I can think of is the time will be different from the image to the
> validation, no?

Don't think that is the reason, otherwise byte-for-byte validation would not work on any computer. Plus, byte-for-byte validation works when using Image for Linux from a bootable USB stick. Thanks.

Re: Byte-for-Byte verify fails using IFW but not IFL

PostPosted: Thu Apr 13, 2017 11:37 am
by Skyglider
TeraByte Support(PP) wrote:
> What model is the Samsung SSD? If it doesn't support Deterministic TRIM
> then it can cause problems with validating.

The SSD is: Samsung 840 EVO 120GB 2.5-Inch SATA III Internal SSD (MZ-7TE120BW)

Byte-for-byte validation works fine if backup is done using IFL on a bootable USB stick. Don't understand why backup of same SSD works using IFL but not IFW.

Was hoping there is a known setting in IFW that could allow it do backups using byte-for-byte verify successfully. If there is no known setting, I can just do my backups using IFL from the bootable USB stick.

Thank you.

Re: Byte-for-Byte verify fails using IFW but not IFL

PostPosted: Thu Apr 13, 2017 11:40 pm
by TeraByte Support
if you're using a current version, you'll find a warning in the ifw.log.


"Skyglider" wrote in message news:13656@public.image...

TeraByte Support(PP) wrote:
> What model is the Samsung SSD? If it doesn't support Deterministic TRIM
> then it can cause problems with validating.

The SSD is: Samsung 840 EVO 120GB 2.5-Inch SATA III Internal SSD
(MZ-7TE120BW)

Byte-for-byte validation works fine if backup is done using IFL on a
bootable USB stick. Don't understand why backup of same SSD works using IFL
but not IFW.



Re: Byte-for-Byte verify fails using IFW but not IFL

PostPosted: Tue Jul 04, 2017 2:39 pm
by timg11
I'm having the same issues.

I recently replaced the SSD in my HTPC (Win 7 /32). It had been backing up with IFW and PhyLock for several years without issues.
Now I installed a Samsung 850 EVO, and I'm getting consistent byte for byte validation failures every time in IFW 3.08.

Nothing else changed (other than the size which went from 64G to 120G).

I tried multiple times, writing the image to a local drive, to a network drive, and I tried the "disable trim"option in settings. In all cases there is a byte-for-byte verify error.

Tell me more about Deterministic Trim? Is there a firmware update or other settings that can fix the issue?
I have searched for firmware updates for the SSD, but I do not find any for the 850 evo.

Thanks!



[7/4/2017 9:04:30 AM] Byte-for-Byte failure at LBA 10926911 offset 0 (32768)
[7/4/2017 9:04:30 AM] Byte-for-Byte comparison failed.
Do not abort if you want to ignore these errors.



[7/4/2017 4:28:12 PM] Byte-for-Byte failure at LBA 11854079 offset 0 (40960)
[7/4/2017 4:28:12 PM] Byte-for-Byte failure at LBA 11854087 offset 0 (45056)
[7/4/2017 4:28:12 PM] Byte-for-Byte comparison failed.
Do not abort if you want to ignore these errors.