Can't find winre.wim when creating boot disk

User discussion and information resource forum for Image products.

Can't find winre.wim when creating boot disk

Postby Larrycleve » Thu Jul 14, 2016 11:38 am

I'm trying to create TBWinRE when I get the error message shown above. Winre.wim isn't in the Windows/system32 directory. It's not in the sources folder in the win10 install disk. I followed the instructions to look for it from install.esd but when it's expanded and copied out there's still no winre.wim. What to do? I tried creating a uefi boot disk and it said it was created successfully but the cd stayed blank. Thanks for your help. :(
Larrycleve
 
Posts: 14
Joined: Tue Jul 12, 2016 8:16 am

Re: Can't find winre.wim when creating boot disk

Postby TeraByte Support(PP) » Thu Jul 14, 2016 12:39 pm

Do you know if WinRE is functional on the system? Have you tried any of the other repair methods in KB 587 (http://www.terabyteunlimited.com/kb/article.php?id=587)?

Are you using the current version of the TBWinRE.cmd script (v1.17) or TBWinPE/RE Builder (v1.5)?

If using the TBWinRE.cmd script, can you provide a copy of the output with the actual error message?

If using TBWinPE/RE Builder (TBWinPE.exe) for the build it will create a log by default, which should have the error message in it.
Paul Purviance
TeraByte Support
TeraByte Support(PP)
 
Posts: 1108
Joined: Thu Aug 11, 2011 5:51 pm

Re: Can't find winre.wim when creating boot disk

Postby Larrycleve » Thu Jul 14, 2016 1:01 pm

That's the article is was using. I followed the section that said find and replace winre.wim. Where do i find the log? I didn't see it in the TBWinre folder. It's the current version of the builder.
Larrycleve
 
Posts: 14
Joined: Tue Jul 12, 2016 8:16 am

Re: Can't find winre.wim when creating boot disk

Postby TeraByte Support(PP) » Thu Jul 14, 2016 1:09 pm

It's the TBWinPE.log file in the TBWinRE folder (same place as TBWinPE.exe). If it doesn't exist make sure the option is enabled in Settings (General tab).

The log can also be accessed by selecting the "Help | View Log" menu item when the program is running.
Paul Purviance
TeraByte Support
TeraByte Support(PP)
 
Posts: 1108
Joined: Thu Aug 11, 2011 5:51 pm

Re: Can't find winre.wim when creating boot disk

Postby Larrycleve » Thu Jul 14, 2016 1:32 pm

I found it. Here it is -
2016-07-13 23:49:46 - ---------------------------------------------------------------------------
2016-07-13 23:49:46 - TBWinPE/RE Builder v1.5
2016-07-13 23:49:46 - Initializing
2016-07-13 23:49:46 - Windows version: Windows 10 Pro [10.0,x64]
2016-07-13 23:49:46 - Initialization complete
2016-07-13 23:50:49 - Verifying build requirements (TBWinRE)
2016-07-13 23:50:49 - Image for Windows 2.99-00 found: G:\Program Files\TeraByte Unlimited\Image for Windows\V2
2016-07-13 23:50:49 - TBIView 4.37 found: C:\Program Files (x86)\TeraByte Unlimited\TBIView
2016-07-13 23:50:49 - TBIMount 1.14 found: C:\Program Files (x86)\TeraByte Unlimited\TBIView
2016-07-13 23:50:49 - TBOSDT 1.61b found (Professional version): C:\Program Files (x86)\TeraByte Unlimited\TeraByte OSD Tool Suite Pro
2016-07-13 23:50:49 - Build source: Windows 10 Pro [10.0] WinRE
2016-07-13 23:50:49 - Locating WinRE image
2016-07-13 23:50:50 - Warning: Unable to locate WinRE at default locations
2016-07-13 23:50:50 - Warning: Backup copy of winre.wim not found
2016-07-13 23:50:51 - Verification complete

2016-07-14 16:24:59 - ---------------------------------------------------------------------------
2016-07-14 16:24:59 - TBWinPE/RE Builder v1.5
2016-07-14 16:24:59 - Initializing
2016-07-14 16:24:59 - Windows version: Windows 10 Pro [10.0,x64]
2016-07-14 16:24:59 - Initialization complete
2016-07-14 16:25:20 - Verifying build requirements (TBWinRE)
2016-07-14 16:25:20 - Image for Windows 2.99-00 found: G:\Program Files\TeraByte Unlimited\Image for Windows\V2
2016-07-14 16:25:20 - TBIView 4.37 found: C:\Program Files (x86)\TeraByte Unlimited\TBIView
2016-07-14 16:25:20 - TBIMount 1.14 found: C:\Program Files (x86)\TeraByte Unlimited\TBIView
2016-07-14 16:25:20 - TBOSDT 1.61b found (Professional version): C:\Program Files (x86)\TeraByte Unlimited\TeraByte OSD Tool Suite Pro
2016-07-14 16:25:21 - Build source: Windows 10 Pro [10.0] WinRE
2016-07-14 16:25:21 - Locating WinRE image
2016-07-14 16:25:21 - Warning: Unable to locate WinRE at default locations
2016-07-14 16:25:21 - Warning: Backup copy of winre.wim not found
2016-07-14 16:25:22 - Verification complete
Larrycleve
 
Posts: 14
Joined: Tue Jul 12, 2016 8:16 am

Re: Can't find winre.wim when creating boot disk

Postby TeraByte Support(PP) » Thu Jul 14, 2016 3:22 pm

It's not finding an installed location.

Output from the following commands (run them from an administrator Command Prompt) would be helpful:
bcdedit /enum all
reagentc /info

Note that if you don't want to copy the text output from the Command Prompt window you can redirect it to a file:
bcdedit /enum all > c:\bcdoutput.txt
reagentc /info > c:\reagentcoutput.txt

If you haven't already, you could run the TBWinRE.cmd script and see if it finds the file.
Paul Purviance
TeraByte Support
TeraByte Support(PP)
 
Posts: 1108
Joined: Thu Aug 11, 2011 5:51 pm

Re: Can't find winre.wim when creating boot disk

Postby Larrycleve » Thu Jul 14, 2016 4:51 pm

here's the results-
Firmware Boot Manager
---------------------
identifier {fwbootmgr}
displayorder {5991886e-4823-11e6-840e-806e6f6e6963}
{bootmgr}
{2d4347d7-48ef-11e6-840f-806e6f6e6963}
timeout 0

Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=\Device\HarddiskVolume2
path \efi\microsoft\boot\bootmgfw.efi
description Windows Boot Manager
locale en-US
inherit {globalsettings}
default {current}
resumeobject {7f215fa1-b895-11db-b50c-c8f94e3b1201}
displayorder {current}
toolsdisplayorder {memdiag}
timeout 30

Firmware Application (101fffff)
-------------------------------
identifier {2d4347d7-48ef-11e6-840f-806e6f6e6963}
device partition=M:
description UEFI: Sony Storage Media

Firmware Application (101fffff)
-------------------------------
identifier {5991886e-4823-11e6-840e-806e6f6e6963}
device partition=\Device\HarddiskVolume2
path \EFI\Microsoft\Boot\bootmgfw.efi
description Windows Boot Manager

Windows Boot Loader
-------------------
identifier {current}
device partition=C:
path \windows\system32\boot\winload.efi
description Microsoft Windows Vista
locale en-US
inherit {bootloadersettings}
osdevice partition=C:
systemroot \Windows
resumeobject {7f215fa1-b895-11db-b50c-c8f94e3b1201}
nx OptIn

Resume from Hibernate
---------------------
identifier {7f215fa1-b895-11db-b50c-c8f94e3b1201}
device partition=C:
path \windows\system32\boot\winresume.efi
description Windows Resume Application
locale en-US
inherit {resumeloadersettings}
filedevice partition=C:
filepath \hiberfil.sys
pae Yes
debugoptionenabled No

Windows Memory Tester
---------------------
identifier {memdiag}
device partition=\Device\HarddiskVolume2
path \boot\memtest.exe
description Windows Memory Diagnostic
locale en-US
inherit {globalsettings}
badmemoryaccess Yes

Windows Legacy OS Loader
------------------------
identifier {ntldr}
device unknown
path \ntldr
description Earlier Version of Windows

EMS Settings
------------
identifier {emssettings}
bootems Yes

Debugger Settings
-----------------
identifier {dbgsettings}
debugtype Serial
debugport 1
baudrate 115200

RAM Defects
-----------
identifier {badmemory}

Global Settings
---------------
identifier {globalsettings}
inherit {dbgsettings}
{emssettings}
{badmemory}

Boot Loader Settings
--------------------
identifier {bootloadersettings}
inherit {globalsettings}

Resume Loader Settings
----------------------
identifier {resumeloadersettings}
inherit {globalsettings}

Windows Recovery Environment (Windows RE) and system reset configuration
Information:

Windows RE status: Disabled
Windows RE location:
Boot Configuration Data (BCD) identifier: 049dfeb1-8fe2-11e3-a664-a206588c8861
Recovery image location:
Recovery image index: 0
Custom image location:
Custom image index: 0
Larrycleve
 
Posts: 14
Joined: Tue Jul 12, 2016 8:16 am

Re: Can't find winre.wim when creating boot disk

Postby Larrycleve » Thu Jul 14, 2016 5:06 pm

I got it to work! From using Google I did reagentc /disable and reagentc /enable and it made the boot disk. I'm going to test it now to make sure it boots but I think it will. I'm also going to try making the uefi boot disk again and see what happens. Thanks for you help.
Larrycleve
 
Posts: 14
Joined: Tue Jul 12, 2016 8:16 am

Re: Can't find winre.wim when creating boot disk

Postby TeraByte Support(PP) » Thu Jul 14, 2016 6:46 pm

Disabling/enabling WinRE using reagentc is one of the steps to try in that KB article. I thought you had tried that already.

Your output shows WinRE wasn't enabled, which would explain why it wasn't being found.
Paul Purviance
TeraByte Support
TeraByte Support(PP)
 
Posts: 1108
Joined: Thu Aug 11, 2011 5:51 pm


Return to Image for DOS/Linux/Windows

cron