Switch to full style
User discussion and information resource forum for BootIt Bare Metal.
Forum rules
Post a reply

Re: Can't disable the GRUB menu

Mon Oct 31, 2016 6:23 pm

One thing I have different in mine is this part:

----BEGIN----
terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
set timeout=30
else
if [ x$feature_timeout_style = xy ] ; then
set timeout_style=hidden
set timeout=0
# Fallback hidden-timeout code in case the timeout_style feature is
# unavailable.
elif sleep --interruptible 0 ; then
set timeout=0
fi
fi
### END /etc/grub.d/00_header ###

----END----

You could also insert the "set timeout=0" command near the end somewhere just to see if overriding it would help. (Any changes in that file would be lost when it's updated. You'd probably want to make a backup copy before playing with it.)

If you do reinstall and it works normally, copy the grub.cfg file out to compare.

Re: Can't disable the GRUB menu

Mon Nov 14, 2016 3:16 pm

Brian,
I finally discovered my problem with the GRUB menu.
I ended up reinstalling Linux Mint as I was frustrated and got the same darn thing!! The GRUB menu was there and I couldn’t skip it either. I struggled with the problem for 2 weeks or so to no avail. Yesterday, I was looking for a UUID for one of my drives and ran a “blkid” from CLI and saw I had a second /root partition on /dev/sdb2 (my “Images” HD, a 3TB conventional HD formatted in GPT). Linux won’t show a second /root or /home partition (or at least I don’t know how to show it) so I couldn’t see it when I was in Linux. I rebooted into BIBM and looked on my “Images” HD from Partition Work, sure enough, I had a /root partition and room for a /home partition on that drive. I must have been going to try install Linux on my “Images” drive at some point. (Obviously a seniors moment as I’m 76.) The bottom line was I had 2 /root partitions, but didn’t know it. In BIBM in the Boot Menu setup it simply showed the HD as GPT. I deleted the /root partition on my “Images” HD and extended the partition to fill the drive and sure enough, my GRUB menu disappeared. I thank you for your efforts to help me, but thought you would like to know what my problem was.

Re: Can't disable the GRUB menu

Mon Nov 14, 2016 3:25 pm

Brian,
I finally discovered my problem with the GRUB menu.
I ended up reinstalling Linux Mint as I was frustrated and got the same darn thing!! The GRUB menu was there and I couldn’t skip it either. I struggled with the problem for 2 weeks or so to no avail. Yesterday, I was looking for a UUID for one of my drives and ran a “blkid” from CLI and saw I had a second /root partition on /dev/sdb2 (my “Images” HD, a 3TB conventional HD formatted in GPT). Linux won’t show a second /root or /home partition (or at least I don’t know how to show it) so I couldn’t see it when I was in Linux. I rebooted into BIBM and looked on my “Images” HD from Partition Work, sure enough, I had a /root partition and room for a /home partition on that drive. I must have been going to try install Linux on my “Images” drive at some point. (Obviously a seniors moment as I’m 76.) The bottom line was I had 2 /root partitions, but didn’t know it. In BIBM in the Boot Menu setup it simply showed the HD as GPT. I deleted the /root partition on my “Images” HD and extended the partition to fill the drive and sure enough, my GRUB menu disappeared. I thank you for your efforts to help me, but thought you would like to know what my problem was.

Re: Can't disable the GRUB menu

Mon Nov 14, 2016 5:33 pm

Bob,

Thanks for the feedback. I might have done something similar. I installed Ubuntu to HD0. 3 partitions, ESP, Linux, Swap. No grub issue. The partitions were imaged and then deleted. I installed Mint to HD0. 3 partitions, ESP, Linux, Swap. No grub issue. The partitions were imaged and then deleted.

HD1 was a GPT disk and the 6 partitions were restored to Free Space on the disk. So 2 ESP were present on HD1. I could boot each OS with EasyUEFI which was installed in Win10 (UEFI) on HD0. Mint had the grub issue and I can't recall whether Ubuntu had the issue as well.
Post a reply